The Navigatrix has been updated. The new website can be found at navigatrix.net.




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Utterly blonde when it comes to computerology so please be gentle with me.

Following all instructions faithfully, I downloaded Navigatrix to an 8 gig stick. This was done on a Win 7 64 bit machine. More by good luck than anything else, I found out how to boot up from the stick.

Unfortunately, the square root of nothing happened. On extremely helpful advice from "Wadda", I started the whole process again and, again, nothing happened.

Just before I threw the Stick, or the Computer, or perhaps even myself, out of the window, I thought - just for fun - Let's try it in my little notebook, which is a 32 bit machine.

Well Knock Me Down with A Wet Feather.....It worked! I had endless hours of fun getting used to it and trying to break it, and even managed to turn it off once I'd finished playing.

However - Some Questions arise:

1. Does it make a difference that I used a 64bit machine to download yet it only works on the 32bit one? After all - I'm booting up from a stick with a different Operating System aren't I?

2. the Navigatrix "package" has an older version of Open Cpn (which I have been using on windows almost since it was invented and I love it).

So: Will it work with Open Cpn 3.2? If so - I'm not sure how to upgrade it on the stick.

And finally.

I cannot get it to open up either my Garmin hockey puck gps or my AIS - both of which work in the Windows system.

Neither will it open up my wifi connection although it does recognise it and I've given it the correct password to digest.

I do hope you can help me but please Write Slowly!! Tony


Top
   
 
 Post subject: Re: 64 bit computer

Joined: 04 Nov 2010, 20:51
Posts: 1062
No worries, Tony, I write slowly anyway.

Quote:
1. Does it make a difference that I used a 64bit machine to download yet it only works on the 32bit one? After all - I'm booting up from a stick with a different Operating System aren't I?


First, a file is a file. It makes no difference how you download the ISO file, as long as it arrives intact. It shouldn't make any difference running 32bit software on a 64bit machine...except sometimes it does. The main difference is 64bit machine can transfer the data in 64bit chunks. The software is expecting 32bit chunks and it should all work out...just sometimes it doesn't.

There are people who are running Navigatrix, or other 32bit Linux distributions, on 64bit machines. Most of them work but occasionally particular hardware is...well, particular. I've no idea why; for me, that falls within the realm of the black arts.

Quote:
2. the Navigatrix "package" has an older version of Open Cpn (which I have been using on windows almost since it was invented and I love it).

So: Will it work with Open Cpn 3.2? If so - I'm not sure how to upgrade it on the stick.



Yes, it is possible. No, I don't recommend doing it.

Apart from the philosophical reasons to resist upgrading; when you run Navigatrix on the stick you are running a "LiveCD". This is a CD version, with limited space, except that you can read/write on it. Modifying the LiveCD in this way shoehorns in an application without modifying the underlying structure...like adding tenants; a live in maid; or stabling horses in your 1 bedroom apartment. Yes, it can be done...but do you really want to?

If you had a hard drive installations of Navigatrix it would be an easier matter and something you could consider.

However, of greater concern to me, or the developers, is your GPS and WIFI....

All GPS function is handled by the GPS daemon (gpsd). The gpsd should pick up your hockey puck within seconds of being plugged in to the USB port. GPSD is one of the most intelligent; transparent; applications I have yet to encounter. The goal of gpsd is to be able to plug in your gps of whatever make and have it work; no drivers; no set up..it just works. Also, by just working; will send gps data to any other application that needs, or requests it.

Run the application "GPS Satellites" (Manta>Navigation>GPS Satellites). Below the "Skyview"; in the "Responses" section, you should see something similar to:

Code:
{"class":"TPV","tag":"MID2","device":"/dev/ttyUSB0","time":1344498166.000,"ept":0.005, "lat":-18.864968797,"lon":-159.802174558,"alt":10.829,"epx":2.241,"epy":2.274,  "epv":9.136,"track":131.3126, "speed":0.057,"climb":-0.111,"mode":3}


Clearly your data will be different or I would have seen you in the cockpit...but you get the idea. You would also see little satellite 'dots' in the Skyview above.

If the gpsd is not picking up your hockey puck the Skyview and Satellite list will be blank and "Responses" will look like:

Code:
{"class":"VERSION","release":"2.95","rev":"2010-10-04T22:39:06",  "proto_major":3,"proto_minor":3}


If you have the former and not the latter double check that the NMEA Data Source (OpenCPN::Wrench>GPS) is pointing to "Network LIBGPS"

If you're still not picking up the gps let us know and we can get down to brass tacks.

The WIFI, unfortunately might be another story. Some newer machines have newer wifi chips that are driven with code that is just slightly different than what it was just a year ago. While they can see the access points they cannot connect...Realtek, I'm talking about you.

Regardless if your machine is new(er) or not it's important to know what we are dealing with to solve the problem.

Open a terminal by hitting 3 keys at the same time <ctrl><alt><t>

When a terminal opens you can find your wifi card with (cut'n'paste):

lspci | grep -i net

Or, if it's a USB wifi device, run

lsusb

to get us pointed in the right direction; paste the results from either/both in your next post and it will give us a better idea what's going on.


Top
   
 
 Post subject: Re: 64 bit computer

Joined: 02 Jul 2012, 12:32
Posts: 33
Moe - Thanks so much!!

Wifi - Got it working and using it to write this. Whilst on my last delivery, my daughter changed the home wifi code!!

64 bit versus 32 bit. OK - shame as the 64bit has a super large screen

GPS. Confirmed I am set to network libgps in Open Cpn tools and the baud rate is 4800. Nothing on the sattelite view screen and the message is the "proto major, proto minor" thing. So I'm a bit stuck there. Without gps, we can't really address the ais problem, yes?

Just noticed at top of this screen, an icon saying TOR disabled and the drop down menu allows me to toggle it on. What is this and should it be On or Off?

Many thanks and, by the way, the version of Open Cpn on the stick is perfectly fine as it is so I'll come back to that if and when I put Navigatrix onto a partition of the hard disc.....baby steps.....

Tony


Top
   
 
 Post subject: Re: 64 bit computer

Joined: 04 Nov 2010, 20:51
Posts: 1062
Tony, let's deal with the easiest and move toward the progressively more complicated.

Regarding your 64bit machine....Yeah, it is a shame. While it could work; it might work....I'm just not the one to troubleshoot it. You will have to tackle that by yourself or find someone brave enough to poke up their head.

TOR is "The Onion Router". It's a clever little bit of wizardry that takes your data packets and wraps other layers around it...like an onion. When you connect to the TOR network by enabling it your data is sent to its ultimate destination, from one node to the next in the network, in which each node knows its predecessor and successor, but no others. Traffic flowing through the network is unwrapped by a symmetric key at each node, which reveals the next downstream node.

What does this all mean?

It preserves anonymity to a great degree. Routers and servers do not know the ultimate source, or destination, of the data request. The TOR network just gets the data and passes it along...from you; back to you.

TOR is included in Navigatrix to provide greater access to information if the need is required and not specifically to provide anonymity.

Let me explain with a real life example.

In Panama, there is a wifi network called "InternetParaTodos". It is a good service provided by the government of Panama to make internet access eventually to everyone in the country. But to make this limited resource available to more people they block high bandwidth sites like Youtube, other video streaming sites, so a small handful of people don't suck all the bandwidth leaving everyone with frustratingly slow internet access. They also block websites deemed socially inappropriate.

Unfortunately, and for whatever conspiratorial reason you want, they also block web sites to many open source sites that are low bandwidth (sourceforge, github, etc.).

It does not provide a cloak of invisibility, but using TOR a person can pass through blocks and access the data s/he wants/needs.



On my "work" machine I upgrade OpenCPN to 3.0.2 to test it just after it came out. For me there is no real added functionality. There have been a few bug fixes, like the "Object Query" window will now close with "OK". And there have been a few stylistic changes which are an improvement, but still take time to become accoustomed. However, the irritation is the default Chart Text font is too large and bold. To each his own.... But, nothing I have done so far keeps my preference from one session to the next. This may have been fixed in subsequent releases.


Now, with regards to your GPS and your AIS, it depends how you plan on receiving the data. You stated the GPS was a Garmin Hockey Puck. If you pump in the AISdata through the sound card it would be un-effected. It comes in via /tmp/aisfifo.

however,for the GPS in OpenCPN the important selection is Network LIBGPS. Baud Rate is handled by gpsd. You could set the rate to 115200 (standard maximum) on any application...if that option were available.

But it looks like your GPS is not getting picked up by gpsd.

For fun let's try a little experiment....(the longer version shouldn't be necessary.)

Open up a terminal <ctrl><alt><t>

Unplug your GPS if it's already plugged in and then plug it back in. If it's not plugged in; plug it in.

Into the open terminal enter (cut 'n' paste for ease.):

sudo dmesg | tail

The vertical line is called a 'pipe' and is located on the backslash key above the <enter> key (US 105 keyboards).

This provides the tail end of a potentially very long log of everything that has happened to the hardware on your computer since it has been fired up.

By having a freshly plugged in GPS, that command will show what happens when you plug it in. If you missed it, or it was so much fun, you can do it again and again.

It will look something like this:
Code:
Moe@Baboo:~ $ dmesg | tail
[12509.624561] usb 2-2: reset full speed USB device using uhci_hcd and address 6
[12509.771114] usb 2-2: cp210x converter now attached to ttyUSB0
[12525.656138] usb 2-2: USB disconnect, address 6
[12525.656697] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0
[12525.656772] cp210x 2-2:1.0: device disconnected
[12540.064602] usb 2-2: new full speed USB device using uhci_hcd and address 7
[12540.231390] usb 2-2: configuration #1 chosen from 1 choice
[12540.237448] cp210x 2-2:1.0: cp210x converter detected
[12540.348106] usb 2-2: reset full speed USB device using uhci_hcd and address 7
[12540.499403] usb 2-2: cp210x converter now attached to ttyUSB0
Moe@Baboo:~ $


The numbers in the [brackets] on the left side indicate how long the computer has been running. The important info for us what and where the recently plugged in GPS is connected.

As you see, my off-brand GPS (cp210x) is now attached to ttyUSB0. Isn't that exciting.

Now you are going to turn off the gpsd by entering into the terminal:

sudo /etc/init.d/gpsd stop

Next we will fire up the gpsd and specifically tell it to look for your GPS because you know where it is.

Enter:

sudo gpsd -b -N -D 4 /dev/ttyUSB0

The last bit "/dev/ttyUSB0" being the "/dev/location_of_you_GPS" that you now know because you ran dmesg | tail.


This starts the gpsd. "-b" just reads the GPS without writing to it; "-n" runs gpsd without being asked; "-N" runs gpsd in the foreground; and "-D 4" makes gpsd chatter about everything, and I mean everything. (Remember to use "-b" just to be 'on the safe side' otherwise the GPS could be latched in inappropriate configurations for less sophisticated software like in Windows. This is the reason for the "write errors" in the output below. If you don't plan on using the GPS with Windows, it's not an issue.)


...just let it set there for a few minutes. The gps' internal almanac might need to updated. Go get a drink. On a cold-cold start of some gps-es it can take up to 29 minutes to update the current almanac and return data...so I'm told. I've never had anything (that worked) take that long.

Eventually, we hope, it will look something like this:
Code:
Moe@Baboo:~ $ gpsd -b -n -N -D 4 /dev/ttyUSB0
gpsd: launching (Version 2.95)
gpsd: listening on port gpsd
gpsd: NTPD shmat(262152,0,0) succeeded, segment 2
gpsd: NTPD shmat(294921,0,0) succeeded, segment 3
gpsd: successfully connected to the DBUS system bus
gpsd: running with effective group ID 1000
gpsd: running with effective user ID 1000
gpsd: opening read-only GPS data source type 3 and at '/dev/ttyUSB0'
gpsd: speed 115200, 8N1
gpsd: attempting USB device enumeration.
gpsd: 1d6b:0002 (bus 1, device 1)
gpsd: 1d6b:0001 (bus 2, device 1)
gpsd: 1d6b:0001 (bus 3, device 1)
gpsd: 1d6b:0001 (bus 4, device 1)
gpsd: 1d6b:0001 (bus 5, device 1)
gpsd: 064e:a102 (bus 1, device 2)
gpsd: 093a:2510 (bus 2, device 5)
gpsd: 10c4:ea60 (bus 2, device 9)
gpsd: vendor/product match with 091e:0003 not found
gpsd: Probing TSIP
gpsd: speed 9600, 8O1
gpsd: speed 115200, 8N1
gpsd: no probe matched...
gpsd: gpsd_activate(): opened GPS (fd 6)
gpsd: speed 4800, 8N1
gpsd: switch_driver(SiRF binary) called...
gpsd: selecting SiRF binary driver...
gpsd: NTPD ntpd_link_activate: 1
gpsd: /dev/ttyUSB0 identified as type SiRF binary (2.011532 sec @ 4800bps)
gpsd: SiRF: baudrate: 4800
gpsd: PPS Create Thread gpsd_ppsmonitor
gpsd: SiRF: unset MID 30...
gpsd: SiRF: Writing error.
gpsd: SiRF: Requesting periodic ecef reports...
gpsd: SiRF: Writing error.
gpsd: SiRF: Requesting periodic tracker reports...
gpsd: SiRF: Writing error.
gpsd: SiRF: Setting DGPS control to use SBAS...
gpsd: SiRF: Writing error.
gpsd: SiRF: Setting SBAS to auto/integrity mode...
gpsd: SiRF: Writing error.
gpsd: SiRF: unset MID 29...
gpsd: SiRF: Writing error.
gpsd: SiRF: Probing for firmware version...
gpsd: SiRF: Writing error.
gpsd: SiRF: Requesting navigation parameters...
gpsd: SiRF: Writing error.
gpsd: SiRF: MND 0x02: Navtype = 0x84, Status = 2, mode = 3
gpsd: SiRF: NTPD SEEN_GPS_2
gpsd: SiRF: NTPD valid time MID 0x02, seen=0x00, time;1344735688.00, leap:15
gpsd: SiRF: MND 0x02: time=1344735688.00 lat=-18.86 lon=-159.80 alt=10.33 track=0.00 speed=0.00 mode=3 status=2 hdop=0.60 used=10 mask={TIME|LATLON|ALTITUDE|SPEED|TRACK|CLIMB|STATUS|MODE|DOP|USED}


...and on, and on, and on.

While it is running open up the GPS Satellite program to see if data spews forth...or OpenCPN.

To stop the blur of data and kill gpsd hit <ctrl><c>


Ok, by now you might be saying, "Sure, Moe, this is a lot of fun...but does it have a purpose?"

Since you can't see me shrug my shoulders I'll tell you that we would hope to find out:

1)How and where your GPS is recognized on your machine.

2)Differentiate a possible problem with gpsd and a possible, what is called a, "hotplug" issue.

3)See how gpsd responds to your gps when they are specifically connected.

3)Find out what's inside your Garmin hockey puck

..and the third-third thing is how to make it work.

If by some miracle it does work. Reboot, or enter in the terminal:

sudo /etc/init.d/gpsd start

to restart the gpsd...or just reboot and it will do it for you.

OR, now that you have done all that...and you gps still doesn't show where your sitting; Cut 'n' paste the output from:

sudo dmesg |tail

and 40 lines, or so of

sudo gpsd -b -n -N -D 4 /dev/whatever_but_should_be_ttyUSB0_or_1_or_ttyUSBsomething.

to a new post and we can take a look-see.


Top
   
 
 Post subject: Re: 64 bit computer

Joined: 04 Nov 2010, 20:51
Posts: 1062
Well, I've got bad news and good news and bad news and good news....

First the bad news;

I borrowed a Garmin 18X gps and plugged it in and got the same results you had.

Oh, wait!...that's the good news; because....

The good news is I figured it out and got the bloody thing to work and return a position.

However, the bad news is don't have a solution for you....at this time.

The good news is when I leave the internet cafe I can get to a clear sky view; replicate what was done; verify that it does actually do what it's suppose to do....then write up the process and figure out how to make it transparent and permanent.
Code:
gpsd: packet from /dev/ttyUSB0 with {ONLINE|SATELLITE|USED|PACKET}
gpsd: Changed mask: {ONLINE|SATELLITE|USED|PACKET} with reliable cycle detection
gpsd: GPS on /dev/ttyUSB0 is offline (0.002023 sec since data)
gpsd: Garmin: Appl, PVT Data Sz: 64
gpsd: Garmin: time_l: 1349654226
gpsd: Garmin: Appl, mode 1, status 0
gpsd: Garmin: UTC Time: 1349654226.000000
gpsd: Garmin: Geoid Separation (MSL-WGS84): from garmin -34.969570, calculated 35.349311
gpsd: Garmin: Alt: 73.673, Epe: 66.354, Eph: 33.192, Epv: 57.456, Fix: 1, Gps_tow: 86242.000000, Lat: -18.652, Lon: -173.983, LonVel: 0.000, LatVel: 0.000, AltVel: 0.000, MslHgt: 34.970, Leap: 16, GarminDays: 8316
gpsd: Garmin: PVT_DATA: time=1349654226.00, lat=-18.65 lon=-173.98 speed=0.00 track=0.00 climb=0.00 epx=48.73 epy=48.73 epv=119.29 mode=1 status=0 mask={}
gpsd: Garmin: ACK
gpsd: modeling errors: mode=0, masks={ONLINE|PACKET}
gpsd: packet from /dev/ttyUSB0 with {ONLINE|PACKET}
gpsd: Garmin: SAT Data Sz: 84
gpsd: Garmin:   Sat   1, snr:    -1, elev:  7, Azmth: 228, Stat: 8
gpsd: Garmin:   Sat  11, snr:    -1, elev:  7, Azmth: 246, Stat: 8
gpsd: Garmin:   Sat  12, snr:    -1, elev: 13, Azmth: 132, Stat: 8
gpsd: Garmin:   Sat  14, snr:    -1, elev: 41, Azmth: 162, Stat: 8
gpsd: Garmin:   Sat  18, snr:    -1, elev: 33, Azmth:  52, Stat: 8
gpsd: Garmin:   Sat  21, snr:    -1, elev:  4, Azmth:  18, Stat: 8
gpsd: Garmin:   Sat  22, snr:    -1, elev: 73, Azmth:  88, Stat: 8
gpsd: Garmin:   Sat  25, snr:    -1, elev: 39, Azmth: 104, Stat: 8
gpsd: Garmin:   Sat  30, snr:    -1, elev: 24, Azmth: 353, Stat: 8
gpsd: Garmin:   Sat  31, snr:    -1, elev: 64, Azmth: 273, Stat: 8
gpsd: Garmin:   Sat  32, snr:    -1, elev:  4, Azmth: 221, Stat: 8
gpsd: Garmin:   Sat 255, snr:     0, elev:  0, Azmth:   0, Stat: 0
gpsd: Garmin: SAT_DATA: visible=11 used=0 mask={SATELLITE|USED}
gpsd: Garmin: ACK


Top
   
 
 Post subject: Re: 64 bit computer

Joined: 04 Nov 2010, 20:51
Posts: 1062
Ok, Tony....to make a long story shorter it turns out the devil was in the daemon.. It looks like something in the first packet of data throws the daemon for a loop from which it can't recover.

This is how you fix it.

Open your favourite terminal. Enter:

Code:
sudo gedit /etc/modprobe.d/blacklist.conf


Scroll down to line 38-39 and you will see:

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps


Place an octothorpe...why say "pound sign", "hash mark", or "number sign" when you can say "octothorpe"?....place one at the beginning of line #39 because the hash mark means the rest of the line is just a comment.

Code:
# most apps now use garmin usb driver directly (Ubuntu: #114565)
#blacklist garmin_gps


Save and close the file.

Go back to your favourite terminal. This is where the fun begins. Enter:

Code:
sudo dpkg-reconfigure gpsd


Make what you see in your terminal look like what you see in the following images. The <tab> key moves you around and cycles through your options if you get too excited and overshoot. <Enter> commits the screen and moves you to the next screen.
Attachment:
LXTerminal_001.png
LXTerminal_001.png [ 16.73 KiB | Viewed 16308 times ]

Attachment:
LXTerminal_002.png
LXTerminal_002.png [ 23.5 KiB | Viewed 16308 times ]

Attachment:
LXTerminal_003.png
LXTerminal_003.png [ 27.7 KiB | Viewed 16308 times ]

This is the only tricky part. You need to add -N to the line with -n -b -G. Order is not important.Spa cing is. Tab to <Ok> when your done and <Enter> to go to the last exciting screen.
Attachment:
LXTerminal_004.png
LXTerminal_004.png [ 20.8 KiB | Viewed 16308 times ]

Attachment:
LXTerminal_005.png
LXTerminal_005.png [ 19.86 KiB | Viewed 16308 times ]


The easiest thing is to reboot. You could make it work with a few more commands, but then you might worry that the thrill won't last. Bite the bullet and reboot to that persistent media.

When it's all back up and running;cross your fingers and use the mouse to call up your next favourite applications after the terminal:

Ray>Navigation>GPS Satellites

Ray>Navigation>GPS Panel

Ray>Navigation>OpenCPN

....and so you don't forget how to use your old friend, the terminal:

cgps
Attachment:
Lefty_015s.png
Lefty_015s.png [ 118.63 KiB | Viewed 16306 times ]


Since the Garmin 18X issues data that makes gpsmon go catatonic don't bother with it.....but there's no room for that anyway.


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Well Moe - that worked like a charm!!!

I'll check in a minute to see if it has affected my other gps, then re-boot a couple of times mixing and matching them just to make sure.

Meanwhile - Since booting from the stick this time (which I havent done for a few days) I seem to have - well, no, I DO have, a very dark screen. And its not the red lightbulb in the bottom right hand corner - that doesn't do anything except alter the screen brightness in Open cpn (which is what its for anyway, yes?

So at the moment, I'm having great difficulty in reading what I'm typing!

bless you, Tony


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Later - Hooray - they both work....bloody marvellous (always nice to have a back-up!)

Now, apart from my screen darkness, Once I've found out how to do a little bit more on the internet other than writing email; like downloading programs and other such fun things, then I may be persuaded to convert this little Samsung to a purely Linux machine.....but there are other things you have to do in Windows, like good house-keeping stuff (clearing out histories, caches, making sure you are up-to-date, defragging....quite a bit to hoist in here, I think....Tony


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 04 Nov 2010, 20:51
Posts: 1062
Whew.....glad it works....it had been driving me crazy, and that's a short trip.

The little lightbulb controls the settings for the whole display, not just OpenCPN. (In fact someone should alter OpenCPN to be more conducive to those people who adjust the RGB settings for the entire display....both in Windows and Linux.)

The settings are adjusted for your location and tthe position of the sun. Out of the box the computer thinks it's in Panama. If you connect a GPS and leave it running for more than 16 minutes it will update the location to the proper one.

Check out http://navigatrix.net/viewtopic.php?f=5&t=195&p=676&hilit=dimmer#p676 to see if this helps out.


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Ah....ok, thanks - I'll try it again (though I rather think its a little too clever for its own good!).

Meanwhile, I'm trying to work my new fave word, Octothorpe, into a conversation!

best for now, T


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Golly, aint it nice when the gps comes up straight away!! And the lighting is sorted, and I'm beginning to think its quite clever after all. I could be described as feeling quite Octothorpic about it all!

Tony


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 04 Nov 2010, 20:51
Posts: 1062
Cool, now I can go to New Caledonia....off tomorrow....or so.


Top
   
 
 Post subject: Re: 64 bit computer and Garmin 18X GPS

Joined: 02 Jul 2012, 12:32
Posts: 33
Fair winds and following seas, Moe. Have a great trip! Tony


Top
   
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


Search for:

Credits © 2010 - 2024