- A Voyager's Companion

GPS not working with Navigatrix
Page 2 of 4

Author:  Moe [ 13 Nov 2013, 19:22 ]
Post subject:  Re: GPS not working with Navigatrix

Straight from the horse's mouth...

The BU-353 is on the list...but the Delorme should work also.

When you fire up Menu> Navigation> GPS Satellites what do you see at the red arrow?
NX-Test.png [ 83.1 KiB | Viewed 48438 times ]
(currently *inside* a brick building)

Author:  CapCouillon [ 16 Nov 2013, 09:40 ]
Post subject:  Re: GPS not working with Navigatrix

BU-353-S4 shooting through cabin overhead. No setup, no drivers... out of the box.
Navigatrix 0.05


Author:  Progenator [ 26 Feb 2014, 17:16 ]
Post subject:  Re: GPS not working with Navigatrix

Hi all, and thanks Moe for all your hard work. I hope this may help some people with GPS problems:

I have just installed Navigatrix on two computers: on the IBM Lenovo X31 notebook Navigatrix works perfectly, the GPS too.

However on the mini ATX D510MO there was strange crash a few minutes after initial installation whilst running Open CPN which happened a second time shortly after. Maybe it was because the cover was off and there was not enough properly directed cooling, or maybe another cause, I really don't know the reason. But the upshot was that the GPS would not work in OpenCPN (though it was working fine in xgps and MMG). Ergo the settings in OpenCPN needed to be redone - ones that would have presumably come up automatically had been lost. I was fortunate enough to have the other computer running and could copy these settings which I hope may be of use to others:

There were two GPS connections open:
1. SERIAL dataport: /tmp/isfifo Baudrate: 4800 priority: 0 accept only sentences: ticked
transmit sentences: ticked
2. NETWORK protocol: gpsd, address: localhost dataport: 2947 priority: 0 checksum: ticked
accept only sentences: ticked

with these entered manually all seems ok so far and the GPS is working.

bon voyage!

Perhaps I should add that the GPS is a model GM720, article number 38-2900 from Clas Ohlson bought in Scandinavia - only about £30 and jolly good as far as I can see. It has a sirfstar 3 chipset and a very strong magnet in the dongle so it's easy to put up anywhere. I've only used it in the house so far but it works well inside by the window - (supplied with installation disc for Windows only), but works out of the box on Navigatrix on the IBM.

EDIT: I have had this little GPS now 2 years -ish now and it's great, never another problem since reconfiguring it in OpenCPN that day highly recommended.
ALSO: recommended is the AIS discriminator-out-lead modification that Rene etc, describes how to do, for small radios. I bought a little Chinese Puching888 radio from him already modified and it has been excellent, it feels really good to have an AIS receiver aboard and for so very little cost. Thanks to Rene and others who have helped me along from the start :)
ALSO I am talking to the QRP group in the UK - Ham radio group that specialises in radio sets using ultra low power (good for your batteries for long voyages). Immediately they have been very kind in giving good, practical, tried info on how to get a small transmitter working on a boat cheaply and using second-hand gear as much as possible (e.g. hoisting a bit of wire up the mast as an antenna instead of buying one). One of the QRP club members has already helped a long distance voyager and spoke to him daily during ocean crossings. This may be a bit off-topic for Navigatrix but I hope it's ok if I post a bit more when I get more info soon, will start a new post if so.

Author:  addboy [ 09 Apr 2016, 19:15 ]
Post subject:  Re: GPS not working with Navigatrix

I have run the GPS reconfigure two times. I get GPS data in the satellite window. But when I open the satellite map the data stops and have the default info in the map window?

Author:  Moe [ 09 Apr 2016, 21:09 ]
Post subject:  Re: GPS not working with Navigatrix

Most people who have gps problems have reconfigured their gps to not work. Let's go back to the "it just broke" thread you started, and figure out how to fix it.

Author:  addboy [ 21 Apr 2016, 19:14 ]
Post subject:  Re: GPS not working with Navigatrix

I'm having GPS trouble to. I can see GPS data in the satellite window and can see the GPS when I list the USB. But do not see any info on the GPS satellite tracking window. I have run GPS recon figure as listed above. Just lost?

Author:  CNC [ 04 May 2016, 13:32 ]
Post subject:  Re: GPS not working with Navigatrix

I need some help for my new GPS, I have buy this one for my Toughbook CF-30 mk3. : ... xydlFS2YVi

The bios see the GPS but Navigatrix fail to see it with the GPS-Satellite or GPS-Monitor and OpenCPN fail also to see it. :cry:

Thank you,

Author:  Moe [ 05 May 2016, 02:13 ]
Post subject:  Re: GPS not working with Navigatrix

We'll have to dig for information on this one because it is integral to the machine.

Your system logs all 'events', and the first place to look is the log and see what the machine sees,

Typically, you would boot up the machine, plug in the 'whatever' and look at the last entries of the log
dmesg | tail
. Generally, the last 10 lines of the log will tell you. If you need more
dmesg | tail -n 20
will give you the last 20 entries into the log.

But, you don't have that option because your gps is built in. If you knew what it was you're looking for
dmesg | grep -i gps
would return all entries with gps, Gps, GPs, to GPS, and all the permutations.

But if the 'critical' information could be 1,2 or 3 lines Before or After the line you search
dmesg | grep-B 3 -A 3 -i gps
...but what if the gps is not called a gps, but a UBlox? It would not return anything. We would then take stabs in the dark.

So...this is a long way of saying probably the best solutions is to capture the entire log as a text file and attach it to a follow up post.

Boot up the system.

Open a terminal and enter
dmesg > ~/Desktop/gps_search.txt
This grabs the entire log, it will be long (1000 lines more or less), and stuffs it into a text file on your Desktop.

Attach it to a post and we can use a text editor to hunt for where in the world this gps has gone.

Then when we find it we can figure out how to tell the system where the data comes out.

Author:  CNC [ 05 May 2016, 06:52 ]
Post subject:  Re: GPS not working with Navigatrix

Hi Moe,

Thanks for helping me with this, in the BIOS the GPS is set to enabled.
Here what you ask me, if Notepad+ is use to open the text file.
It will display it line by line.

gps_search.txt [72.2 KiB]
Downloaded 572 times

Author:  Moe [ 05 May 2016, 09:04 ]
Post subject:  Re: GPS not working with Navigatrix

It's called "toughbook" for a reason.

I don't see any thing that is calling itself a gps, but if you swear it's installed, enabled, and in working order we can poke at the three serial connectors you see 1.4 seconds into the boot process
[ 1.411480] Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
[ 1.432277] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[ 1.453043] 00:08: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 115200) is a 16550A
[ 1.473804] 00:09: ttyS2 at I/O 0x3e8 (irq = 7, base_baud = 115200) is a 16550A
Open a terminal and methodically go down the list of setting the serial port speed and looking for output...oh, and before we get into possible permission issues, claim all the power you can by being a super user,
sudo -s
will give you a root terminal for the following commands.
stty -F /dev/ttyS2 ispeed 4800 && cat </dev/ttyS2
stty -F /dev/ttyS1 ispeed 4800 && cat </dev/ttyS1
stty -F /dev/ttyS0 ispeed 4800 && cat </dev/ttyS0
If that isn't enough fun you can run xgps (GPS Satellites) on the side to see if the narrow box (Responses) under the "Sky View" has any change at all when you do these exciting tests.

If nothing is there, nothing will happen. None of these commands make permanent changes.

If there are any errors, let us know what they are.

Edit: fixed the typo of lower case (minuscule) S in the /dev/ttySx.

Author:  CNC [ 05 May 2016, 09:48 ]
Post subject:  Re: GPS not working with Navigatrix

Here what I am getting:

For command line: stty -F /dev/ttyS2 ispeed 4800 && cat </dev/ttys2
Got this: stty: /dev/ttyS2 : impossible d'effectuer toutes les opérations demandées

Translate = impossible to perform all required operations

Same answer for the 3 command lines.

I have find this .pdf info for Linux GPS, maybe it could help?

GPSforUbuntuLinux.pdf [4.97 MiB]
Downloaded 594 times

Author:  CNC [ 05 May 2016, 09:54 ]
Post subject:  Re: GPS not working with Navigatrix

Oupsss! I forget to enter sudo -s code, will do all again not long.

Author:  Moe [ 05 May 2016, 09:55 ]
Post subject:  Re: GPS not working with Navigatrix

bugger, typos

Author:  Moe [ 05 May 2016, 09:56 ]
Post subject:  Re: GPS not working with Navigatrix

stty -F /dev/ttyS2 ispeed 4800 && cat </dev/ttyS2

in all the commands...sorry

Author:  CNC [ 05 May 2016, 10:08 ]
Post subject:  Re: GPS not working with Navigatrix

Ok I run all the command lines, I have to change the end of each one the small 's' give me a error no file of this name find. So I use a big 'S' and did not get a error message.

All command lines give me noting.

Author:  CNC [ 05 May 2016, 10:30 ]
Post subject:  Re: GPS not working with Navigatrix

Hi Moe,

I have a second harddrive that I could use to install Windows 7 Pro.
So that I could test the GPS to see if it will work under Windows.

If it fail to work on Windows, it will never work on Navigatrix.

Here email answer I got from the seller:

"As we mentioned before, we never test it with Linux distribution before but for your information, you should not expect the GPS to appear as a separate device in device list manager, it is serial device that doesn't need driver and as long the system has installed driver for the serial port it should take only a simple configuration in the navigation software which port to use and the speed. In most of the cases it should be com port 3 and the speed has to be set to 4800bps.

We will suggest if you can install Windows XP or Win7 (follow the installation instructions) just to test and confirm that the GPS is installed properly and works then you can continue and look for configuration solution under Linux."

So it will take me maybe the day to do it, Windows update is a little long to download.

Will give you news later,

Author:  CNC [ 05 May 2016, 13:15 ]
Post subject:  Re: GPS not working with Navigatrix

I got it working under Windows 7 Pro 32 bit.
I got GPS data with this software, VisualGPS:

Now I will try to make work OpenCPN,

Author:  CNC [ 05 May 2016, 15:18 ]
Post subject:  Re: GPS not working with Navigatrix

The GPS is working with OpenCPN running under Windows 7, the GPS use the COM3 rate set at 4800, I see no name. Do you know a way to get the GPS name info, so it will be more easy to find it when I will reinstall Navigatrix?

Author:  Moe [ 05 May 2016, 20:28 ]
Post subject:  Re: GPS not working with Navigatrix

The COM ports are typically defined as:
  • COM1: I/O port 0x3F8, IRQ 4
  • COM2: I/O port 0x2F8, IRQ 3
  • COM3: I/O port 0x3E8, IRQ 4
  • COM4: I/O port 0x2E8, IRQ 3

At the hard address 0x3e8 you have
[ 1.473804] 00:09: ttyS2 at I/O 0x3e8 (irq = 7, base_baud = 115200) is a 16550A
This corresponds with COM3, where the gps is located.

The interrupt (IRQ) is different, but it's a different kernel. I don't think it's an issue, but unfortunately, that is the extent of what I know about interrupts.

Like most computers you have
1.411480] Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
and if you look at your directory you will see /dev/ttyS0.../ttyS31 for your 32 ports.

The stty -F /dev/ttySx ispeed 4800 && cat </dev/ttySx is a simple, 'set the device at 4800baud and display the contents in the terminal' command. This is a first step in trobuleshooting from the GPSD folk (

In reading about other people's problems, one person said he tried all 32 ports. While I admire the determination, I can only say that hope springs eternal, as there isn't any difference, (or shouldn't be any difference out of the box), with the last 10...20...or 30 devices. As I recall he was unsuccessful.

However, another person said he had success with
stty -F /dev/ttyS3 ispeed 4800 && cat </dev/ttyS3
It makes no sense, but he did make the same typo I did. It's hard to argue with success, except he also speculated his Bluetooth was causing interference, but offered nothing more. So who knows?

I'll do some more investigation. In the meantime, you could try pointing the GPSD directly at the suspected location.

First turn off the GPSD.
sudo killall gpsd
Remove the communication socket it creates
sudo rm /var/run/gpsd.socket
Then restart it with an increased level of diagnostic, point it directly toward a possible source
gpsd -D 5 -N -n /dev/ttyS2
If there is nothing, it will tell you
netty@netty:~$ gpsd -D 5 -N -n /dev/ttyACM1
gpsd:INFO: launching (Version 3.9)
gpsd:IO: opening IPv4 socket
gpsd:IO: opening IPv6 socket
gpsd:INFO: listening on port gpsd
gpsd:PROG: NTPD shmat(65538,0,0) succeeded, segment 2
gpsd:PROG: NTPD shmat(98307,0,0) succeeded, segment 3
gpsd:PROG: successfully connected to the DBUS system bus
gpsd:PROG: PPS thread launched
gpsd:INFO: NTPD ntpd_link_activate: 1
gpsd:INFO: stashing device /dev/ttyACM1 at slot 0
gpsd:PROG: no /etc/gpsd/device-hook present, skipped running ACTIVATE hook
gpsd:INFO: opening read-only GPS data source type 0 and at '/dev/ttyACM1'
gpsd:ERROR: device open failed: No such file or directory - retrying read-only
gpsd:ERROR: read-only device open failed: No such file or directory
gpsd:ERROR: initial GPS device /dev/ttyACM1 open failed
<ctl><c>will end it.

See what sort of errors you get. If they are different than the last three above, cut and paste them for us to look deeper. It's a relatively short, painless process at this point. There is no need to try all 32 spots, but you can poke around a bit. The worse that can happen, aside from spending 20 seconds per test, is you are told 'no'. Use the UP arrow to re-enter the last command for editing and easier entry.

If we are lucky, the wizardry that is GPSD can make some sense out of it and you'll see
gpsd:DATA: GPRMC time is 1462497759.000000 = 2016-05-06T01:22:39.00Z
gpsd:PROG: GPRMC sentence timestamped 12239.00.
gpsd:PROG: GPRMC ends a reporting cycle.
gpsd:IO: <= GPS: $GPVTG,0.0,T,,M,0.00,N,0.0,K*50
gpsd:DATA: packet type 1 from /dev/ttyACM0 with {ONLINE|PACKET}
and kill it with <ctl><c>
^Cgpsd:WARN: received terminating signal 2.
gpsd:INFO: closing GPS=/dev/ttyACM0 (6)
gpsd:PROG: no /etc/gpsd/device-hook present, skipped running DEACTIVATE hook
gpsd:WARN: exiting.

Author:  CNC [ 06 May 2016, 07:13 ]
Post subject:  Re: GPS not working with Navigatrix

Hi Moe,

For what I could see in Windows divise COM3 is on IRQ 7.
I have reinstall a fresh new Navigatrix from the USB key. I did not update it and have keep it in English for now. After that I have it all install, I run the code to get gps_search2.txt, I then check the ttyS2 IRQ, it is the 7 aslo. So I run the code "sudo -s" and "stty -F /dev/ttyS2 ispeed 4800 && cat </dev/ttyS2" it give me a error like before, that GPS is there I know it, so I run the 2 code again, and magic, magic and more magic happen. :o

I open the GPS monitor but it still display noting.

I print some screen shot from Window and Navigatrix for you to see the magic that happen. :D

How do I set the rate 4800 permanent? :?:

GPS_Info.rar [248.1 KiB]
Downloaded 577 times

Page 2 of 4 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group