- A Voyager's Companion

Make It Work!
Page 2 of 2

Author:  rgleason [ 01 Mar 2014, 19:11 ]
Post subject:  Re: Make It Work!

From Oct 16, 2013

In short, this has not been resolved on my end. The Sandisk Flash USB still show up under Hard Drives and I have been through the drill.... I don't understand the French very well. Was there a resolution?

I see that others also have difficulites too.

Moe, Thank you. This looks crystal clear to me. I don't know why I did not think of going into USB. Very helpful!
Navagatrix here we come. Also Thank you David and Capt-Corilon

Ok here are the results Summary: It does not appear to work on this Sandisk Cruzer Glide USB Drive [16GB] which appears under Computer > Hard Disks.

Control Panel > System > Device Manager > Disk Drives > Sandisk Cruzer Glide USB Drive > Right Click > Properties > Tab Police -Optimize for performance and Tab Volume Click POPULATE the [F] and 15252mb Show in the window. Click OK.

Start, double click navagatrix_setup.exe, run screen appears, finds navagatrix.iso
Step 3 Select USB. Cannot see or select [F].

Have also tried full reformat of the USB drive, wiping out all SanDisk programs, and a quick format. Still does not work.

Have tried putting a 2gb Memorex USB in at same time on one occassion. Shows as [E:/] Drive and it also shows up in the Navagatrix_Setup.exe!!! It is listed in the "Removeable Drive" List instead of Hard Drives. The other 16GB one shows up under "Hard Driives" as [F:] and will not show up in the iso install program. I wonder why? Different manufacture, driver, etc?

Is the 2gb USB from Memorex a large enough drive? I think the install will work with that drive. Also I could only find USB 2.0 keys -are they ok?

Thanks so much.

Author:  rgleason [ 01 Mar 2014, 19:15 ]
Post subject:  Re: Make It Work!

Yes, have done that in two Computers, one an old Win XP and another Win7x64. Still a problem.

Have you checked for a conflict in Disk Management and/or tried assigning an alternate drive letter? The problem is sometimes caused by a conflict in the assigned drive letter if that letter was previously used by a different device that wasn't present when the currently unavailable device was first installed.

I believe most of these types of problems were fixed in XP-SP2. At least for XP-Pro. Not sure about Home edition.<blah, blah, bla

Author:  Moe [ 01 Mar 2014, 22:06 ]
Post subject:  Re: Make It Work!

I think its a U3 problem. Next time I'm in town I'll fetch a new SanDisk stick and chew on it.

As far as I can tell there is a tiny-tiny partition on the stick that makes it different.

Formatting; reformatting; and formatting again does nothing to this mostly invisible partition.

Erasing the file that are pre-installed doesn't cut it either.

This is some info I found:

I can't vouch for any of it because I've not tested any of it...but that might be a direction to look.

Author:  Atmo [ 09 Mar 2014, 16:35 ]
Post subject:  Re: Make It Work!


same problem. After the disk creator could not read the drive I formatted it. No luck.
I went to the San disk Website to download The U3 removal tool. The tool says there is no U3 device. Same with the U3 installer I tried. It also states no Us device.
Mine is a Cruzer Glide 16 GB.
Guess the formatting did that and there seems to be no way to access the underlying structure.
My 16GB Kingston drive with Nx on it gave up it's ghost and does not work at all anymore. (Maybe that was part of my comport problems with Pactor,..if I'm lucky...)
In summary, no more Navigatrix for me till I find a drive on which I can install it!
Further research implemented that Microsoft is the culprit behind it because they want the sticks to show up as a drive for Windows 8.

I will go to town today and fetch another one of the San disk drives and play around with the tools it comes with.
Maybe I get lucky and can change the drive number.
I found something in a forum stating you have to chose a tick box asking if you want to install programs on the stick.

Let's see....,

I want my Nx back! :evil: :)

Author:  Atmo [ 14 Mar 2014, 15:49 ]
Post subject:  Re: Make It Work!


now we have a real problem. I went and exchanged my new Sandisk drive for another one. Also no U3 software on it.
Couldn't find a way change it into a removable drive.
According to the Net there is none....
Now, the old Kingston I was running Nx of doesn't work anymore.
All the new sticks are licensed for windows 8, meaning they all show up as Hard drives.

No way to change that.

Would there be a way to tweak the disk creator to accept a disk drive?
Or is it possible to do a Hard drive install on the USB drive?
I just couldn't find a way to get Nx to install anymore.

Is there a way to use the Iso somehow without the disk creator?

I spend a week now trying to figure to change the new drives into removable ones, only way, if at all, seems to be Linux based.
But, Catch 22, that'exactly what I'm trying to get installed.....

There must be a way to install Nx...


Atmo :oops: :cry: :roll:

Author:  Moe [ 14 Mar 2014, 20:27 ]
Post subject:  Re: Make It Work!

I'll mail you a stick. Email me an address.

Author:  Moe [ 15 Mar 2014, 00:26 ]
Post subject:  Re: Make It Work!

Give this a go first.


Author:  Atmo [ 16 Mar 2014, 17:25 ]
Post subject:  Re: Make It Work!

Uhh yeah,

thanx Moe, my mail is skyatmo at

Elloh elloh,

Thanx Moe for your offer, my maail is skyatmo..jahoo.cohm
Last night on the boat I found ... .9.5.2.exe which made it possible for me to install Kali Linux on the Sandisk stick. It looks the same like the Disk Creator used by Nx, but it has the option to install on a drive. Disadvantage is though that you have to choose your Linux system via a drop down menu and Nx is not listed. So I choose Kali Linux which was sleeping in a Folder.
I just couldn't fire it up because the Plop manager on my Toughbook Dos level doesn't let me choose USB, only Navigatrix for start up.
I'll try later with XP on my Macbook. Idea is to install Navigatrix with the help of Kali Linux on the stick where Kali Linux is established. Or, may be there is a way to change the drive into a removable one with Kali.
Interesting stuff....
Meanwhile I'll try to order a stick which works with Nx as long as they are still available...

I will get it working at one stage and if I do everybody will be able to.......



Author:  Moe [ 16 Mar 2014, 18:39 ]
Post subject:  Re: Make It Work!

At the bottom of the pulldown menu in the application you referenced is an option:

Try Unlisted Linux ISO

...and then locate and select the Navigatrix ISO in Step 2.

The Australian Post Office said the USB stick was non-deliverable because it wasn't a valid address.

Author:  Atmo [ 17 Mar 2014, 01:30 ]
Post subject:  Re: Make It Work!

o.k., skyatmo at that is...(trying to keep that automated spam out...),
thanx, going to try that other option now since the Plop manager couldn't start Kali on the Mac either..... :? :roll:

Author:  Atmo [ 17 Mar 2014, 03:38 ]
Post subject:  Re: Make It Work!


fantastic tool, installation worked fine....., but, the Plop manager can't open a disk.....
There is a Windows EXE(within Nx opened in Win or Mac) where you can change the Plop to start with a different drive letter, but that doesn't work either. I mean I could change to E but that didn't do the trick either. All the files on the stick seem to be o.k.
Next step would be finding a cd and burn the Plop manager to it and try to start Nx from there.
I doubt it though that this will work.. Guess Microsoft just found a way to keep anybody from installing Programs or anything from sticks for a while.
I am just not knowledgeable enough to sort out why you can#t start a Mac or Windows machine from a Stick which titillates itself as a Hard drive.
In my book it should be easy just to change the letter....

Let's see if there are still removable drives around....

Maybe there is a way to make an extra partition on the hard drive with Debian and install Nx there, but then again I can't access the Hard disk install without having Nx working on a stick before....

looks like it is getting harder by the day.
I won't give up!



Author:  Moe [ 17 Mar 2014, 05:58 ]
Post subject:  Re: Make It Work!

Sorry, I don't know anything about Plop.

I took a look at it once a few years ago, but I've never had a machine that wouldn't boot from a USB.

Maybe someone else can weight in on this.

Author:  Atmo [ 18 Mar 2014, 04:56 ]
Post subject:  Re: Make It Work!

I used the boot manager which comes with Nx5 . Both my machines can't boot from the Sandisk drive. I also returned the drive to make sure it's not a faulty stick.
No chance. Out of whatever reason the bootmanager doesn't see the drive.
I managed to install Nx sucessfully on the drive but can't start it.

Now I found an old 4GB micro Sd card , chucked that in a reader and installed Nx without a problem.
Back on the boat I will see to a hard drive install on the Toughbook before the Sd card fails.
Question: How are we going to install Nx now you can't by removable drive sticks anymore? :D :)

Author:  Moe [ 18 Mar 2014, 05:51 ]
Post subject:  Re: Make It Work!

The question I'm trying to ask is:

Do these machines boot to *any* USB device?

If they do; the it shouldn't be a Plop solution. Something else is going Plop getting in the way.

The creation of the stick is not a boot question at all, but a situation that involves your current OS, the physical USB, the installer program, and the operator of those three components.

The scary thing is this is how I even cook breakfast. I isolate the trouble and find the cause. Develop a solution that is fitting for the task; see that it doesn't bring down civilisation; and doesn't end up in the Regret Pile. When it's over...we all get a beer in the shade.

Author:  Atmo [ 18 Mar 2014, 19:36 ]
Post subject:  Re: Make It Work!

Time for a summary I think.

That's the Macbook I'm using.
Hardware Overview:

Model Name: MacBook
Model Identifier: MacBook3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 4 GB
Bus Speed: 800 MHz
Boot ROM Version: MB31.008E.B02
SMC Version (system): 1.24f3
Serial Number (system): WQ7462PFZ63
Hardware UUID: 4CCA683D-19F7-52D7-91B3-528EE4FCB045
Sudden Motion Sensor:
State: Enabled

Windows Xp is installed on a Bootcamp Partition. Bootcamp comes with the Operating system. (Os 10.58)
In order to be abel to boot from a stick I launch the Windows Partition.
In order to get to the Bios I had to install the bootmanager "Plop" via the tool folder in Nx showing up in windows.
After doing this successfully I got the choice which partition or USB to boot from after choosing the windows partition.
That works flawless with older SD Cards and USB Sticks but not with the "New World Order" ones. (Windows 8 )

Plop manager seems to need a removable drive to actually be able to boot from it!
Drives seen as Hard Drive are not recognised!

The other machine is an old Panasonic Toughbook CF 18 with an ancient Windows Celeron 900Ghz processor. It also needs Plop to be able to boot from USB.
Again, for that you need a pre Windows 8 architecture stick.
Fantastic is that even all the Digitizer and Wifi options are working faster then with XP!
Only problem is to get Airmail working with a USB Converter for the SCS Pactor modem.

So, since a lot of sailors I meet are using Macintosh Computers, this is to state that Nx is working fine on Bootcamp. I have to stress the point that Bootcamp is not an emulation but a proper Partition in Fat 32; the Mac Partition is working on Journal and it is not possible to interchange files between the Partitions.
But it is possible, no idea why, to access and exchange certain files, actually all files readable by Nx, via mounting the Mac Volume in Nx.
( You can also open your stick in Mac and just drag your files into a folder.., both ways work....)
Funny thing remaining is the problem with UsB converters and Airmail like on the Toughbook.
Additional it can't see Wifi Networks but Nx states it had past connections....

Please be advised that due to lack of proper It education I use the "Blackbox" approach. Meaning I create an Input and see what comes out the other end without knowing what's happening inside.
To be abel to do that really speaks for Nx and the way it is set up.
Phantastic job, looking at other Linux websites I wouldn't be abel to install a Linux System at all....

Moe, to answer your Question, no, my machines don't seem to be able to boot from USB without the Boot manager.
The San Disk question is solved too. After using the Penlinux tool I was able to install Nx on the San Disk but couldn't launch it.
Now I used somebody's four year old Acer Pc, started on Bios, choose the Sandisk and it worked straight away.

If you need the Plop crutch due to the age or Os of your machine, you just have to make sure to have an older drive too.
(Will try to write a mail to Mr. Plop, maybe it's just an easy add on...)

It all comes down to what you have stated in the documentation already.
(You need a computer abel to boot from USB)
Remaining though is that the disk creator won't work with the new sticks, but the penlinux one works fine.

Apologies for diverting so much energy to the case.
I'll do a Hard drive install now on the Toughbook and see to the Converter issue with Airmail. I'll also try the "Wine" update, hope I can work that.

Thank all, especially Moe, for all the support.
We'll get it working better and better!


Atmo :D

Author:  Hrlyclassic [ 21 Aug 2016, 18:58 ]
Post subject:  Re: Make It Work!

For anyone who is still dealing with this I've gotten mine to work on Windows 8 laptop now . I went into boot set up with f10, enabled legacy there and directed it to boot from disk. Legacy wanted me to press esc key during startup to go to a boot menu that showed my usb stick an walls came tumbling down an she opened! Now the process of learning how to use it! Much Aloha to everyone's posts that got me too the end!
Bobby G
Kailua Kona, HI

Author:  Progenator [ 14 Dec 2016, 05:34 ]
Post subject:  Re: Make It Work!

something that just might help people trying to use/make bootable USB sticks:

Having played with the tiny RaspberryPi computer the past year or so I learned that SD cards are used in effect instead of hard drives - the Operating System (OS) is installed on the SD card and runs from that. Each SD card is rated by its manufacturer from 1-10 in terms of its speed and performance before it is sold (and it's printed on the SD card sticker itself (or its packaging) so you know what you are buying, in theory).

However, there are certain SD memory cards that do and don't work with the RasPi, irrespective as to whether one buys the 'super-duper' expensive ones or 'cheapies'. The results are interesting, and sometimes surprising, and there is even a huge comparison table online put up by people who have tested loads of SD card batches from myriad different manufacturers - one certainly does not always get what one pays for.

Even certain batches of cards from the best manufacturers are not always usable for certain purposes (e.g. booting), whilst they are seemingly fine for others!

The performance and suitability of different batches from each manufacturer eventually gets listed on the internet comparison table. I suspect the same may be true for USB memory sticks. They are so cheap nowadays that it's worth trying another one if the first doesn't work. There may for all I know even be a list of which USB stick batches boot well, which perform well and which don't (I have never looked). Computer memory is a strange animal and not a completely tame one.

The effect *is* dependent on each batch or batch series, not on individual SD cards. The phenomenon is by now rather well documented in relation to SD cards.

I'm not a memory technician - and so at risk of getting shot down in flames, I speculate that as plug-in memory, they are not entirely dissimilar to USB sticks and may suffer the same issues?! What I can say is that there seems to be a pattern in that some USB sticks work fine, others create issues.

PS later addition: Please excuse the typo, before editing I had noted memory cards wrongly as XD cards - they are of course SD cards - now the text is corrected

Author:  addboy [ 12 Aug 2017, 13:35 ]
Post subject:  Re: Make It Work!

I have used the window installer to reinstall to USB drive after a failed HD install and now it will not boot up? All I get is flashing curser.

Page 2 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group