- A Voyager's Companion

Garmin GPS 18x and NEW computer
Page 1 of 1

Author:  bvimatelot [ 13 Dec 2014, 00:18 ]
Post subject:  Garmin GPS 18x and NEW computer

Old samsung netbook finally died on me during the last delivery so I've just bought a new computer. Using my original navigatrix stick, I'm having difficulty making it boot from the stick. Its an Acer Aspire 64bit machine.

So, I tried the stick on yet another machine (Gateway 64 bit and the dear old garmin is back to the proto thing in xgps. I tried reconfiguring but that didn't work.

So now I'm wondering if I've mucked up the stick somehow?

Tony (still blonde, I'm sorry to say)

Author:  Moe [ 14 Dec 2014, 06:20 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

How'bout a little more info, Tony?

What did it do or not do? Does it run in one machine and not the other? What have you tried, etc, etc.

To troubleshoot you isolate issues and deal with problems separately, one variable at a time, so you don't 'do and undo' and then scratch your head wondering why it's not working.

Author:  bvimatelot [ 15 Dec 2014, 00:29 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

Hi Moe - thanks for that! OK so I found out how to boot the new computer from the stick: I have to use "legacy" instead of the other set of initials. This is a shame but at least I'm able to read Navigatrix.

However - its the same problem I had which you very kindly solved for me last time!

This time, after digging out your instructions, I am still getting the Proto major and minor again. Even after re-configuring the gps, So it doesn't look as if the reconfiguring is working. The stick's checksum is correct.

I'm on my other machine at the moment so can't send you any read-outs until tomorrow.

Good to talk to you again!


Author:  Moe [ 21 Dec 2014, 02:09 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

You've heard the expression, 'insanity is doing the same thing, but expecting different results'. The corollary to that expression is 'sanity is getting the same result from the same input'. 'Sanity' is repeatability.

There's a old new term floating around. It's called a Heisenbug, a computer bug, or error that disappears, or changes behaviour when you go looking for it. It's inconsistent. Sometimes it works properly and sometimes it doesn't. These bugs are difficult to find because they are buried deep and the complexity of the program masks nuances that give erratic output.

The term 'heisenbug' is used partly in jest because one aspect of computers and the programs that run on them is their consistency. They only do what they are told.

Things that work will continue to work until something causes them to not work. Things that are fixed will stay fixed until something reverts, or changes, it into a non-working state.

The fix for your gps will work as long as the environment is the same. It is. It is the same gps, the same code and the same interface.

If it doesn't work migrating from one machine to the next you need to look at the hardware connection, or the any errors made in reconfiguration.

Given the lifespan of USB connectors, the fact it's a new machine, and your propensity for typos, I'd double/triple check your reconfiguration.

Author:  kortushka [ 17 Aug 2015, 11:50 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

Hi to all!

I have the same problem setting up this antenna on an old Dell Inspiron 6000.

One time I've managed to set up the antenna on an acer aspire running ubuntu 12.04 just downloading the gps babbel package and loading manually the garmin_gps module via console(here

Now I've done all of that and I've also followed the tips of Moe but with no luck.

After loading the module and reconfiguring the gpsd, here what the terminal reports after typing 'dmesg | grep -i tty':
[ 0.000000] console [tty0] enabled
[ 27.656852] Bluetooth: RFCOMM TTY layer initialized
[ 33.499974] ttyS0: LSR safety check engaged!
[ 33.506784] ttyS0: LSR safety check engaged!
[ 819.172918] usbserial: USB Serial support registered for Garmin GPS usb/tty
[ 819.175193] garmin_gps 5-2:1.0: Garmin GPS usb/tty converter detected
[ 819.176751] usb 5-2: Garmin GPS usb/tty converter now attached to ttyUSB0

but checking the connection with xgps it gives no results(proto:minor, proto:maior)

I've also followed this troubleshooting guide( but it ended nowhere.

Does anybody have any other suggestions?

Author:  Moe [ 18 Aug 2015, 05:26 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

I'm not sure what those tips that you followed were. I'm also not sure what other changes you have made.

gpsbabel is part of Navigatrix, so when you say you've added it, I'm not sure you're running Navigatrix and we could waste a lot of time with assumptions that should not have been made.

Author:  kortushka [ 18 Aug 2015, 16:36 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

I'm sorry if I've confused you with such a long story :)

What I mean is that I have trouble in setting up the garmin gps 18x antenna on a dell inspiron 6000 that is running Navigatrix.

I've followed your advices(in another topic in this forum) about reconfiguring gpsd via console but it didn't work, so I followed also the troubleshooting guide found on the gpsd site (that I linked before) and it didn't work too.

All the original packages of Navigatrix are still there, untouched.

It seems to me that maybe the gps is set on the right port (from the report of the dmesg command on the console) but something else prevents it from being recognized by xgps.

Am I wrong? Could you suggest me anything else?


Author:  Moe [ 18 Aug 2015, 18:45 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

gpsd finds the gps regardless of where it's plugged in. It then gives one location for gps data. This is one reason why it is preferable. No matter when or where, the data is always in the same place.

But, our good pals at Garmin aren't as consistent. Their devices have differing ways of talking and modules (drivers) to communicate to a system. The trick is to insert the appropriate module, or blacklist the garmin module that would naturally be used.

There are a few pitfalls in troubleshooting that should be avoided. Changing more than one variable at one time. You won't know if one fixes the problem and the another does nothing...or breaks it again.

In a similar vein, making one change toward resolution but subsequent changes undermine any progress...the left hand not knowing what the right hand is doing.

I have trouble with typographical errors. I gloss over spelling, spacing, or punctuation errors only pausing if it doesn't make sense. Computers only do what they are told. They are stupid and they hate us.

This leads to the most damnable confusion sometimes when changes are made --that will work--, but the machine was not told to use those changes, by either restarting the process, logging off and on, or rebooting, hence the origin of the old IT joke, "Have you tried turning it off and back on?"

This is a long way of saying:
  • Start from a known place, so you can isolate variables
  • Make deliberate changes, but if stabbing in the dark make only one at a time.
  • Ensure those changes are tested

You are getting device recognition
[ 819.172918] usbserial: USB Serial support registered for Garmin GPS usb/tty
[ 819.175193] garmin_gps 5-2:1.0: Garmin GPS usb/tty converter detected
[ 819.176751] usb 5-2: Garmin GPS usb/tty converter now attached to ttyUSB0

As I recall, the 18x Garmin hockey puck required that gpsd was not configure as a daemon (the -N switch).

Starting off from ground zero (but not scraping back to bare metal), that would be my first move, in this case, because running gpsd as a normal process doesn't alter its function, but eliminates a daemon process as a variable.

I would then, after rebooting, insert the gps into a slot and execute
dmesg | tail
it returns the last 10 lines of the system log
moe@io:~$ dmesg |tail
[178800.710041] usb 2-1.2: new full-speed USB device number 8 using ehci-pci
[178800.798559] usb 2-1.2: New USB device found, idVendor=10c4, idProduct=ea60
[178800.798567] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[178800.798572] usb 2-1.2: Product: CP2104 USB to UART Bridge Controller
[178800.798576] usb 2-1.2: Manufacturer: Silicon Labs
[178800.798579] usb 2-1.2: SerialNumber: 001BC735
[178801.829935] usbcore: registered new interface driver cp210x
[178801.829963] usbserial: USB Serial support registered for cp210x
[178801.830011] cp210x 2-1.2:1.0: cp210x converter detected
[178801.831721] usb 2-1.2: cp210x converter now attached to ttyUSB1
from there you can look to see what modules are loaded.
to see what's happening.

Author:  kortushka [ 22 Aug 2015, 10:55 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

Ok, so here is what I've done:

1) reconfigured gpsd adding the -N option,saved and rebooted.

2)here the console report of the dmesg | tail command after plugging the gps:

[ 549.240317] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 549.240336] usb 5-2: USB disconnect, device number 100
[ 549.480215] usb 5-2: new full-speed USB device number 101 using uhci_hcd
[ 549.622905] usb 5-2: New USB device found, idVendor=091e, idProduct=0003
[ 549.622918] usb 5-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 550.976972] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 550.976991] usb 5-2: USB disconnect, device number 101
[ 551.216495] usb 5-2: new full-speed USB device number 102 using uhci_hcd
[ 551.358877] usb 5-2: New USB device found, idVendor=091e, idProduct=0003
[ 551.358890] usb 5-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0

3) lsmod reports this:

Module Size Used by

gpio_ich 16384 0
dell_laptop 16384 0
wl 6152192 0
dcdbas 16384 1 dell_laptop
i8k 16384 0
rfcomm 61440 12
bnep 20480 2
dm_multipath 24576 0
pcmcia 53248 0
scsi_dh 16384 1 dm_multipath
ipw2200 139264 0
libipw 36864 1 ipw2200
joydev 20480 0
lib80211 16384 1 libipw
yenta_socket 40960 0
serio_raw 16384 0
pcmcia_rsrc 20480 1 yenta_socket
cfg80211 450560 3 wl,libipw,ipw2200
pcmcia_core 24576 3 pcmcia,pcmcia_rsrc,yenta_socket
snd_intel8x0 40960 2
btusb 32768 0
snd_ac97_codec 106496 1 snd_intel8x0
lpc_ich 20480 0
shpchp 32768 0
ac97_bus 16384 1 snd_ac97_codec
bluetooth 430080 22 bnep,btusb,rfcomm
nfsd 253952 2
auth_rpcgss 49152 1 nfsd
nfs_acl 16384 1 nfsd
nfs 208896 0
lockd 81920 2 nfs,nfsd
grace 16384 2 nfsd,lockd
sunrpc 274432 6 nfs,nfsd,auth_rpcgss,lockd,nfs_acl
binfmt_misc 20480 1
fscache 57344 1 nfs
parport_pc 32768 0
ppdev 20480 0
snd_pcm_oss 49152 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 94208 3 snd_pcm_oss,snd_ac97_codec,snd_intel8x0
mac_hid 16384 0
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 28672 1 snd_seq_midi
snd_seq 57344 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 28672 2 snd_pcm,snd_seq
snd 69632 13 snd_pcm_oss,snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device,snd_mixer_oss
soundcore 16384 1 snd
lp 16384 0
parport 40960 3 lp,ppdev,parport_pc
batman_adv 147456 0
libcrc32c 16384 1 batman_adv
btrfs 917504 0
raid10 49152 0
raid456 86016 0
async_raid6_recov 16384 1 raid456
async_memcpy 16384 2 raid456,async_raid6_recov
async_pq 16384 2 raid456,async_raid6_recov
async_xor 16384 3 async_pq,raid456,async_raid6_recov
async_tx 16384 5 async_pq,raid456,async_xor,async_memcpy,async_raid6_recov
xor 28672 2 btrfs,async_xor
raid6_pq 98304 3 async_pq,btrfs,async_raid6_recov
raid1 36864 0
raid0 20480 0
multipath 16384 0
linear 16384 0
dm_mirror 24576 0
dm_region_hash 20480 1 dm_mirror
dm_log 20480 2 dm_region_hash,dm_mirror
radeon 1425408 2
i2c_algo_bit 16384 1 radeon
ttm 86016 1 radeon
b44 36864 0
firewire_ohci 36864 0
pata_acpi 16384 0
firewire_core 65536 1 firewire_ohci
ssb 57344 1 b44
psmouse 102400 0
ahci 28672 0
mii 16384 1 b44
drm_kms_helper 106496 1 radeon
sdhci_pci 20480 0
crc_itu_t 16384 1 firewire_core
libahci 32768 1 ahci
sdhci 45056 1 sdhci_pci
drm 282624 5 ttm,drm_kms_helper,radeon
video 20480 0

It seems the garmin module is not loaded automatically when the device is plugged in the usb socket, right?

Author:  Moe [ 30 Aug 2015, 02:38 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

Ok, the first thing to note is the sloppy USB connection
[ 550.976991] usb 5-2: USB disconnect, device number 101
[ 551.216495] usb 5-2: new full-speed USB device number 102 using uhci_hcd
At the first entry, the gps disconnects a quarter of a second it reconnects to an incremented device number.

Sometimes the connection will break and not reconnect. It's plugged in, but not connected.

If it reconnects before the software acknowledges a 'dud' device it will be attached before the software there is a new device that it should interrogate and get to know.

This is how you fix it, as I said in this post (

If you have done this, and it still doesn't work, I suggest we start looking at the make/break connections/contactors in the USB plug.

Open your favourite terminal. Enter:

sudo medit /etc/modprobe.d/blacklist.conf

Scroll down to line 38-39 and you will see:

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

Place an octothorpe...why say "pound sign", "hash mark", or "number sign" when you can say "octothorpe"? one at the beginning of line #39 because the hash mark means the rest of the line is just a comment.

# most apps now use garmin usb driver directly (Ubuntu: #114565)
#blacklist garmin_gps

Save and close the file.

Go back to your favourite terminal. This is where the fun begins. Enter:

sudo dpkg-reconfigure gpsd

Make what you see in your terminal look like what you see in the following images. The <tab> key moves you around and cycles through your options if you get too excited and overshoot. <Enter> commits the screen and moves you to the next screen.



This is the only tricky part. You need to add -N to the line with -n -b -G. Order is not important.Spa cing is. Tab to <Ok> when your done and <Enter> to go to the last exciting screen.


The easiest thing is to reboot. You could make it work with a few more commands, but then you might worry that the thrill won't last. Bite the bullet and reboot to that persistent media.

When it's all back up and running;cross your fingers and use the mouse to call up your next favourite applications after the terminal:

Ray>Navigation>GPS Satellites

Ray>Navigation>GPS Panel


....and so you don't forget how to use your old friend, the terminal:


Since the Garmin 18X issues data that makes gpsmon go catatonic don't bother with it.....but there's no room for that anyway.

Author:  kortushka [ 31 Aug 2015, 16:12 ]
Post subject:  Re: Garmin GPS 18x and NEW computer

Well, I fixed the usb issue simply switching to another plug on the pc.

I have strictly followed your guide step by step, reconfigured gpsd and edited the .conf file and...nothing worked :)

A bit frustrated and lacking ideas to solve the issue, I tried desperately the gpsd configuration I had when running Ubuntu on my pc:

LXTerminal_004.png [ 20.8 KiB | Viewed 18052 times ]

I just erased all the options to gpsd of this step and saved.

Then I loaded manually the gps_garmin module via terminal (sudo modprobe garmin_gps); after a while I typed on the terminal 'gpsmon'....and the data from the gps started to flow :D

I opened also Gpspanel, Gpsatellite and Opencpn, too: everything seems working! I tried to reboot a couple of times and it kept doing the job.

I am no Linux expert so I actually don't know why but it works!

Thanks a lot Moe, your kind and precise advices were greatly appreciated!

Good wind

Author:  Moe [ 02 Sep 2015, 04:07 ]
Post subject:  Re: Garmin GPS 18x and NEW computer


Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group