The Navigatrix has been updated. The new website can be found at

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Issue -- Open CPN not working?

Joined: 11 Mar 2015, 13:07
Posts: 1
Hello, new to Navigatrix but somewhat familiar with Linux/Unix though a little out of practice!

I have a new BU-353-S4 USB GPS Receiver ... I ran Navigatrix off a CD and everything with all the applicaitons worked perfectly! No issues ... so I installed the OS on my hardrive... then the fun and flakiness started!

The first times running with the USB device attached, OpenCPN seemed to work fine with the unit though the connection droped out a few times and no longer showed GPS connectivity on the top right of OpenCPN (I upgraded to 4.0 btw). As time went on, the GPS unit works with everything "except" openCPN... works and shows proper information with MMG and XPGPS and Instrument Pannel so I know the GPS unit itself is working/functioning. One difference... when I type the the following terminal command, t I don't see the streaming NEMA data... I get "stty: /dev/ttyUSB0: Device or resource busy" returned... the command:

stty -F /dev/ttyUSB0 ispeed 4800 && cat < /dev/ttyUSB0

Frustrated ... Navigatorix was regular under CD boot but not after full install ...


 Post subject: Re: Issue -- Open CPN not working?

Joined: 04 Nov 2010, 20:51
Posts: 1062
There might be a few things going on.

Since other gps applications return data, check the setting of your OpenCPN. It should look like
Selection_007.png [ 89.28 KiB | Viewed 15822 times ]
All gps data is picked up and distributed by the gpsd.

When you attach a gps, the gpsd talks to it and distributes the data via port 2947 of the localhost (your machine)

The reason when you execute the command, stty -F /dev/ttyUSB0 ispeed 4800 && cat < /dev/ttyUSB0 that you get stty: /dev/ttyUSB0: Device or resource busy is because it is busy, it's talking to the gpsd.

You have two options:
  • kill the gpsd and then run the command, or
  • telnet localhost 2947 and after it connects, ?WATCH={"enable":true,"json":true} or ?WATCH={"enable":true,"nmea":true} for a manufactured NMEA sentence (just close the terminal when you're done, it's easier than trying to turn it off)

moe@fissionchips:~$ telnet localhost 2947
Connected to localhost.
Escape character is '^]'.
...but I don't know why you would want to do either option (other than it's cool) when there's cgps, xgps, and other applications to see the streaming data.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

Search for:

Credits © 2010 - 2024