The Navigatrix has been updated. The new website can be found at navigatrix.net.




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: password

Joined: 11 Oct 2014, 03:27
Posts: 13
Hi Moe
Long time since Apataki 8-)
Thank you so much for Navigatrix, but each time I install it on a computer , I'm unable to set a password to boot. If i ask a password to start Navigatrix, everyhting ok untill the forth letter or number or sign,so eachtime I've installed it without password to start.
Any suggestion?


Top
   
 
 Post subject: Re: password

Joined: 04 Nov 2010, 20:51
Posts: 1062
Merci, beaucoup de gens font Navigatrix possible. Je espère que tout va bien avec vous et Gerard. Aussi étrange que cela puisse sembler, je voudrais revenir à Apataki Carenage passer plus de temps.

(For those who don't know,Apitaki Carenage is the best DIY boatyard in the South Pacific)

I am having a little trouble understanding what you want to do.

First off, on the LiveCD version of Navigatrix, the user is nx. This user (nx) does not require a password. This requirement has been circumvented by /etc/sudoers.d/00navigatrix which instructs the system in specific instances to grant access without a password. By default, as a security measure, the root password is not set (I'm told, technically it is set, but it is unknown to anyone/thing, alive or not alive.)

...but that doesn't really apply to you.

Setting passwords with sudo passwd is a straight forward process, if you have sudo access. It is always the command followed by the user for whom you wish to change/set the password. If no user is stated it will change the password of the current user logged in.
Quote:
moe@io:~$ sudo passwd root <---to change/set the 'user' root's password
[sudo] password for moe: <-- for the 'sudo' command in the line above
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
moe@io:~$ sudo passwd
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
moe@io:~$
Ok, that is how you set/change the password for anyone on a system you have sudo privileges .

To log on to the system, either automagically, or with a password, is controlled by the Light Desktop Manager configuration file found at /etc/lightdm/lightdm.conf . For auto-login, it looks like this
Quote:
[SeatDefaults]
autologin-guest=false
autologin-user=moe
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
greeter-setup-script=/usr/bin/numlockx on
user-session=Navigatrix
If I would want the system to ask for a password when it boots, you place a #, like this
Code:
# autologin-session=lightdm-autologin
Although not necessary, I place a space after the # for readability.

Adding a # to the beginning of any line and it become a "comment" and not something the system will use. Essentially it is a comment to a human that could be used to improve, fix, or revert the code.

This file can be modified via
Code:
sudo medit /etc/lightdm/lightdm.conf
Save, and exit.

Was this close to what you wanted to know?


Top
   
 
 Post subject: Re: password

Joined: 11 Oct 2014, 03:27
Posts: 13
Hi
"If I would want the system to ask for a password when it boots"
That's what I was looking for, but I'm so beginner with Linux Gnu , I have to learn somewhere the basis to use your information, thank you, I'll find how to !!


Top
   
 
 Post subject: Re: password

Joined: 04 Nov 2010, 20:51
Posts: 1062
That is what you do. open a terminal
Code:
sudo medit /etc/lightdm/lightdm.conf
Then you go down 5 lines and place a # at the beginning, so it looks like
Code:
# autologin-session=lightdm-autologin
Save, and exit.

You will be asked for a password on the next boot.


Top
   
 
 Post subject: Re: password

Joined: 11 Oct 2014, 03:27
Posts: 13
Sorry but it's not working:

zelda@zelda-AOA150:~$ sudo medit /etc/lightdm/lightdm.conf
[sudo] password for zelda:

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::lang after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::indent after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::strip after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::add-newline after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::wrap-mode after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::show-line-numbers after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::tab-width after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::word-chars after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::indent-use-tabs after class was initialised

(medit:3010): GLib-GObject-WARNING **: Attempt to add property MooEditConfig::indent-width after class was initialised
zelda@zelda-AOA150:~$


Top
   
 
 Post subject: Re: password

Joined: 04 Nov 2010, 20:51
Posts: 1062
Yes, I know the terminal shows errors, but the text editor appears in another window that pops up. To not see the errors you would use
Code:
gksudo medit /etc/lightdm/lightdm.conf
look for the pop up window.


Top
   
 
 Post subject: Re: password

Joined: 11 Oct 2014, 03:27
Posts: 13
I've done it, it appears like that when I open it now but still no passwd asked on start, I don't know what I 'm doing wrong, thanks for your patience

[SeatDefaults]
autologin-guest=false
autologin-user=zelda
autologin-user-timeout=0
# autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
greeter-setup-script=/usr/bin/numlockx on
user-session=Navigatrix


Top
   
 
 Post subject: Re: password

Joined: 04 Nov 2010, 20:51
Posts: 1062
Let me look into the problem, because it works when I add/remove the # on the line autologin-session=lightdm-autologin....it's a mystery.


Top
   
 
 Post subject: Re: password

Joined: 04 Nov 2010, 20:51
Posts: 1062
I'm sorry, Zelda. I can't replicate the problem.

It's like Adrian's trouble with wvdial.conf, no matter what I do, it works every time.

It's hard to fix if I can't break it. Sorry.


Top
   
 
 Post subject: password

Joined: 11 Oct 2014, 03:27
Posts: 13
Hello
I 'd like to disable passwords request on wake up (after suspend and hibernation), how to do it ?
Thank you


Top
   
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


Search for:

Credits © 2010 - 2023