Navigatrix.net - A Voyager's Companion
http://navigatrix.net/

openCPN charts
http://navigatrix.net/viewtopic.php?f=4&t=807
Page 1 of 1

Author:  Henke [ 16 Jun 2015, 11:33 ]
Post subject:  openCPN charts

Anybody a bit more computer literate than me(most people), can probably fix this easy.
I manage to install the updated Navigatrix :P but when I tried to use openCPN, no charts were loaded, so I tried to load charts, but not doing to well. now it says "rtlsdr" and Failed to open! when I start OCPN. It seems I can load chart of Argentina, and Pacific NOOA charts.

Author:  Moe [ 16 Jun 2015, 14:03 ]
Post subject:  Re: openCPN charts

You have all the plugins enabled. Disable the ones you don't want/need...like, in your case,rtlsdr.
Attachment:
Selection_018.png
Selection_018.png [ 129.53 KiB | Viewed 17547 times ]
Place all charts in the directory you want AND that is listed in the configuration settings.

You could use /home/Charts, which is default,or one of your own choosing.
Henke wrote:
I can load chart of Argentina, and Pacific NOOA charts.
not a problem if that's what you want, or expected.

Force re-build the index, if necessary or..what the heck, just because.

Author:  Henke [ 17 Jun 2015, 01:16 ]
Post subject:  Re: openCPN charts

Hi Moe,

Thanks for your quick reply!

I disabled the RTDSLR, no problem.

I can't find any charts though. I've tried both options; scan database and force rebuild. when i press apply, i can see a dialog square flash for a 10th of a second, so can't read.The actual chart screen behind the settings goes grey. Doesn't look right.
And Nooa and Argentina charts are great if you're there, but I just got back to the Med.
Seems like I have no charts?

I tried to load a picture of the screen, but it just shows file:///home/henke/Desktop/2015-06-17_081324_1366x768.png

Author:  Moe [ 17 Jun 2015, 03:43 ]
Post subject:  Re: openCPN charts

Here's a little trick.

Go to a terminal <ctrl><alt><t>, and enter
Code:
sudo updatedb
This updates an index of all the files on the system.

When it's do generating the index
Code:
locate -i .kap
the -i flag says .KAP, Kap, kAp, etc, will return if found.

This will show you where all those kap charts are.
Quote:
moe@io:~$ locate -i .kap
/home/Charts/NewZealand/NZ14051.kap
/home/Charts/NewZealand/NZ14061.kap
/home/Charts/NewZealand/NZ14065.kap
..etc.

Author:  Henke [ 17 Jun 2015, 06:57 ]
Post subject:  Re: openCPN charts

Asks me for a sudo password

googled it, and says it's the password used when installing ubuntu.

Only Password i ever was told is navigatrix, or possibly NX

i have tried all kinds, but not letting me in.

And I just installed this newer version a few days ago, no passwords at all

Any ideas?

Appreciate your patience...

Author:  Moe [ 17 Jun 2015, 07:21 ]
Post subject:  Re: openCPN charts

When you say 'install' are you talking about a USB, are a hard drive installation?

USB should be password overridden. Hard drive installation is the one the person who did the installation gave for the user ID created.

If is USB try
Code:
sudo passwd nx
Enter a short password that is not a pain to type. At this level of the game, passwords only should be used as a reminder to not change anything in those areas while drunk. Because you will mess something up, regardless of how idiot proof it is made to be.

Anyway...Try the command again after you have set a user password for nx (the one you use).

This will/should set a password for any details that got left out. If that is even the case? Because it's a mystery to me.

Author:  Henke [ 17 Jun 2015, 13:43 ]
Post subject:  Re: openCPN charts

Well, I guess it's a mystery. I managed to install it on my hard drive. all by myself. David told me there was a newer version.

I ran the older version of Navigatrix, until last week. David installed on this laptop in Panama last year for me.
What's weird is I don't remember anhything at all about passwords or user id during installation.

So unfortunately your explanation of how to do it on a usb doesn't help.

Maybe I screwed something up during installation? should i reinstall the whole shebang?

BTW, i tried nx, NX, navigatrix etc as password

Author:  Moe [ 18 Jun 2015, 01:05 ]
Post subject:  Re: openCPN charts

I hope David didn't laugh maniacally when he told you of the update.

This is a way to reset your password when it appears all hope is lost.

Boot up the machine with a LiveCD installation of Navigatrix.

Open the File Manager and mount the partion that contains the root of the system on the hard drive by clicking on the partitions list in the left panel.
Attachment:
Mount-ID-root.png
Mount-ID-root.png [ 83.16 KiB | Viewed 17528 times ]
It will look similar to this
Attachment:
Mount--root.png
Mount--root.png [ 100.29 KiB | Viewed 17528 times ]
Now, execute df -h in a terminal
Attachment:
Mount-found-root.png
Mount-found-root.png [ 44.37 KiB | Viewed 17528 times ]
Note the /dev location (sda1, sda3, sdb2, whatever).

Place that information in the command sudo mount /dev/sd{whatever} /mnt
Quote:
sudo mount /dev/sda1 /mnt
After success, (because you have matched the proper partition) enter
Code:
sudo chroot /mnt
to change over to the new mounted root filesystem.

Enter the command to change the password of your userid (whatever it was. My userid conveniently is moe , you remember yours).
Quote:
passwd moe
I'm asked to enter a password twice. Keep it simple. (It's this easy to bypass when one has physical access.)

The whole process looks like
Quote:
nx@nx:~$ sudo mount /dev/sda1 /mnt
nx@nx:~$ sudo chroot /mnt
root@nx:/# passwd moe
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
root@nx:/#
Quit and reboot, removing the USB at the proper time.
Code:
exit
Code:
sudo reboot

Now you will have your password to execute all the sudo commands.

((yes, one step can be removed from this process, but it takes longer to explain the shortcut))

Author:  Henke [ 18 Jun 2015, 03:36 ]
Post subject:  Re: openCPN charts

Well, David did say I didn't really need it. Guess it was is way of saying don't do it! haha

OK, this requires my full attention, so it'll have to wait until the weekend because too long days of work now.

As soon as I have succeded, I'll let you know!

Author:  David [ 18 Jun 2015, 18:23 ]
Post subject:  Re: openCPN charts

The reason that you dont have any charts is most likely because you did not copy any charts into the charts folder after installing navigatrix. It doesnt come with charts. You have to put some in! And for this you wont even need the password :-)
If you dont have any charts take a look here, there is several links to maxsea chart downloads: http://campus.sailoog.com/mod/page/view.php?id=158 ... these downloads may be illegal in some countries.

Author:  Henke [ 19 Jun 2015, 03:21 ]
Post subject:  Re: openCPN charts

David, no charts eh? ok, i'll look into that tonight after work.
I guessed it was something I missed when installing it.
But how did I manage to install it on the new boat computer i ut in on Oya/ you told me i assume?

Guess I have something to do over the weekend! :-)

Adnd look, I am using the forum instead of calling you!

Author:  Henke [ 19 Jun 2015, 14:24 ]
Post subject:  Re: openCPN charts

Holy s##t! downloaded froma that site, and after fighting with asking password again!!! i managed to open it it after pressing a lot of buttons without any clue whatsoever, the charts loaded!!! :shock: :D :D
Thanks Moe and David!!! have a great weekend!

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/