- A Voyager's Companion

Airmail GRIB problem
Page 1 of 1

Author:  gmkyte [ 16 Aug 2013, 10:32 ]
Post subject:  Airmail GRIB problem

Hello, thanks for a great compilation of programs. However, I'm stuck! Have been running V0.4 for several years with no problem and have tried to use V0.5 this weekend. All seems OK except from within Airmail, Catalogs, Grib files, the laptop locks up for about one minute, then the world map appears. The hand and rectangular selectors appear to operate the wrong way round, and when grabbing the screen to drag the map to show England, the map element of the display turns solid orange. The situation is exactly the same running from SD card and installed on hard disk versions on two Eee PCs, an Eee PC 1008 and a PEM 1015, the same ones that I had V0.4 on with no issues. I have tried booting with 'old graphics hardware', tried downloading the iso file twice more and using different 8 Gb SD cards, but the same problem is there. I am totally baffled. Any assistance greatly appreciated. Regards Graham, S/Y QUASAR IV.

Author:  Moe [ 16 Aug 2013, 11:27 ]
Post subject:  Re: Airmail GRIB problem

It looks like a Wine problem when it draws the map.

I just ran a test and it grinds away at trying to render the graphics for that map.

It succeeded, but it's on a machine with a hot processor, swap file, 128MB video memory and 4GB system memory. Once it was rendered it was fine. I'm guessing the demands on your setup give it a graphical infarct.

I'll get some data rather than impressions, but the kneejerk impression is getting a different version of Wine and/or Airmail. Easy installed (and perhaps unnecessary) on the hard drive; less so on the external media. At this point I don't know if there is tmp file that could be enlarged or if we could be so lucky for a fix.

Author:  gmkyte [ 16 Aug 2013, 11:57 ]
Post subject:  Re: Airmail GRIB problem

Moe, thanks for the quick response. I'll wait so see what can be done. I have also just run it on my main PC which is a dual core P3400, 4Gb RAM, 1Gb graphics card, etc, but running from the Class 10 SD card, same snag. Not sure if this info helps or hinders! Rgds Graham

Author:  Moe [ 16 Aug 2013, 12:24 ]
Post subject:  Re: Airmail GRIB problem

Yeah, I think it helps, but at 3AM I am suseptable to ideas that are just wrong in the light of day.

Currently trying it on a little doesn't look good.

2 minutes 45 seconds to render the screen.

I would call it more atrocious red.

Until someone can figure this out try this cheap workaround.

Wait for the image to is forever. After the map is visible increase the scale using the zoom glass on the left, two, or three clicks (more?). See if that is at least workable with your setup. This was how it became usable on the netbook.

But, yes, there is a problem there.

Author:  David [ 16 Aug 2013, 15:40 ]
Post subject:  Re: Airmail GRIB problem

The problem seems to be within wine. I messured 43 seconds to load the map in nx0.4 and 98 seconds in nx0.5.
No matter if its a harddisk installation or running from usb. After updateing wine to version 1.6 the map loads faster... it takes 38 seconds now.
And i have no problems with moving the map. Here is how to update wine to the latest version using a harddisk installation:
Open a Terminal (can be done by pressing ctrl+alt+t at the same time) then copy and paste the follwing lines.
sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get -y install wine
There will be a new ISO download soon, with the new wine integrated and a couple of other fixes and updates.

Author:  gmkyte [ 16 Aug 2013, 23:58 ]
Post subject:  Re: Airmail GRIB problem

Many thanks indeed. I'll try that.

Author:  Moe [ 17 Aug 2013, 00:54 ]
Post subject:  Re: Airmail GRIB problem

When I switched, as David suggested, to Wine 1.6. The big machine went from 40 seconds to 7 seconds to render. The netbook went from 2:45 to 55 seconds.

For some the addition space required for 94.4MB in wine packages and the 79.9MB footprint for a wine installation will push some USB installations to full capacity on the persistence files. The packages can be deleted after install if you don't run out of space in the process. sudo apt-get clean will do the trick, removing all stored packages.

run command 'man apt-get' for more information wrote:
clean clears out the local repository of retrieved package files.
It removes everything but the lock file from
/var/cache/apt/archives/ and /var/cache/apt/archives/partial/.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group