- A Voyager's Companion

Files wont save/Persistency Problem
Page 1 of 1

Author:  lschmid [ 22 Apr 2014, 00:03 ]
Post subject:  Files wont save/Persistency Problem

After installing the most recent version, I am unable to save files and the program does not seem to create a separate persistent data area. When I boot the first time, I selected "create 4GB persistency area." However, when I am in the OS, it shows data area size of ~490MB for /home/nx/. The Documents and Library directories are shown as symbolic links. When I click on the links the directories ar "not valid." I am not able to find any other data areas than the 490MB area even though it is a 32 GB USB stick.

I have tried using the "Other Options" and "More Options" selections but when I hit Enter, I get a black screen that say: "BOOT:" that's it. Everything I enter at that point say invalid command.

I don't know if I got a good or bad download but it all looks good when I am in the OS. I was able to get my charts working in OpenCPN and get on the net. But, I lost all my info once I rebooted. The descriptions in the forum by Moe and others didn't help, nor did the documentation.

Any help would be appreciated. Seems like a great Linux implementation and I look forward to having it working.


Author:  Moe [ 22 Apr 2014, 02:11 ]
Post subject:  Re: Files wont save/Persistency Problem

I'm trying to imagine what is going on and only coming up with "it's not working'".

I'm also concerned that what I've written in the past was worthless...there is no guarentee.

When the screen goes black and just gives you the boot: it has fallen out of the LiveCD menu system.

Try this....go back there. At boot: enter:
and then <Return>.

This should call up the script to recreate a 4GB persistence file.

If this fails we need to look at the ISO integrity (md5sum) or some other you made the LiveCD...bad karma as a child...whatever.

Author:  Moe [ 22 Apr 2014, 02:33 ]
Post subject:  Re: Files wont save/Persistency Problem

I will add, the size of the persistence is a little deceptive. /home/nx...and what follows is part of the persistent overlay. The rest is / (root); /usr; /lib; /etc...are all part of it.

The objective file size is casper-rw on the USB when the filesystem on the USB is viewed from another OS.

Author:  lschmid [ 22 Apr 2014, 08:52 ]
Post subject:  Re: Files wont save/Persistency Problem

OK, when I type fix4 at the boot: prompt its says: "cannot find kernel."
That would make sense if, as you said, it has lallen out of the live system.

Is it possible that the latest build, which I downloaded Saturday, could have a line of code missing in the menu system or a misdirected link something like that? When I ran the checksum it came back with the correct code. Like I said, everything else seems to be working great.

When I look at the usb file structure in Ubuntu it shows casper directory (no -rw), its 2.1GB. Iterestingly, the Documents and Library directories are shown as directories, not as symbolic links (shortcuts). However, they are empty.

Author:  Moe [ 22 Apr 2014, 10:23 ]
Post subject:  Re: Files wont save/Persistency Problem

The part about certain directories are sticking out there when you look at the filesystem 'from another system'...what you just a swanky way to save the junk that collects in those sorts of directories if you need an out-of-the-box system but a safe-box that won't delete photos, document, bowling scores.

The other amazing thing is those directory names, Pictures, Charts,...Video, translate to the other active languages in the LiveCD.

Thereby your puntajes_de_bolo.txt file on your Escritorio is the same puntajes_de_bolos.txt on your if you stuff up the system and have to remake the persistence will still be on your Bureau when you recover.

It's clever 'rub your head and pat your belly' style programming that has "Hello World" beaten on several levels and should be as durable, but can falter if you start flipping languages back and forth like the UN.

...unfortunately all this was to set you up to let you down.

We have a fat32 32GB USB
ISO with valid md5
Default UNetbootin creation from Ubuntu system...or Startup Disk Creator...or dd something something from the command line?

I'm wondering if the persistence is read-only, but the rest of your stuff is stowed in the proper places masking a permission issue and fact it was Colonel Mustard, with a lead pipe, in the Library...but it doesn't follow logically. I don't see how it could happen.

Please describe the process....

Author:  lschmid [ 22 Apr 2014, 11:44 ]
Post subject:  Re: Files wont save/Persistency Problem

What I did was download the file using the torrent download. I have Ubuntu on my main computer. I then used Unetbootin to format the usb for live boot with the file I downloaded. It is a 32GB usb drive. Once created, I put the usb into my netbook computer and booted. I selected 4GB persistency from the menu and hit enter. Then, the screen flickers and the menu disappears for a second or two and then reappears in a slightly higher resolution for a few seconds and then boots directly into Navigatrix. It didn't take a few minutes to format and then ask me to reboot like it says in the documentation. It just goes straight to the OS. I have a sense that it is skipping a step during the load process.

Author:  Moe [ 22 Apr 2014, 17:16 ]
Post subject:  Re: Files wont save/Persistency Problem

I hate to be dense, but...I am.

So, the first boot of the system you went to the "other options" and then selected "create 4GB persistency"...?

I ask because creating 4GB persistent file takes a few minutes and I don't recall any option to reboot or not at this stage of the I'm just trying to figure out what you are seeing.

Creating a persistent file is a lot of fun. For a taste of danger you could delete your persistent file, casper-rw, via your Ubuntu system and get a running start.

It should take a few minutes of a relaxing blue screen with the exciting line creating 4000 MB persistent file and then auto-magically finish the boot process while gather your composure.

The screen does screen things as the system switches to better suited video drivers for your machine. This is the nature of LiveCDs that run on different computers. It starts out with something that works for everyone. As hardware is detected a more suitable modules is used.

Author:  lschmid [ 22 Apr 2014, 17:53 ]
Post subject:  Re: Files wont save/Persistency Problem

I booted the USB and got a menu. One of the options is create 4GB persistent data. I selected that. Then it booted into the system. When I rebooted is when I found that my data was lost. I then used the more options selection. That's when I found the "boot:" with black screen problem. I then tried to delete the persistent data option and then did the 4GB selection again. Each time I get an OS without the library and documents directories as shown in the documentation.

Also, when I get the menu it looks different than the menu shown in the documentation. There is no 6GB data area selection.

Is it possible that because I got a very recent build that the boot loader was modified incorrectly before it was put out for distribution?

What do you mean by delete the casper-rw from Ubuntu to get a running start? Can I create a persistent data area using Ubuntu? And, how does deleting it help?

When I put the USB Stick in the other computer with Ubuntu loaded something different happens. I am able to see the casper directory and the library directory. In the library directory it contains some pdf documents. In Navigatrix they are not there.


Author:  Moe [ 23 Apr 2014, 01:58 ]
Post subject:  Re: Files wont save/Persistency Problem

The boot loaders come from either the navigatrix-setup.exe in MSWindows or from /usr/lib/syslinux in the Linux system used to create the LiveCD.

There use to be a problem that Unetbootin was using a renegade Syslinux...but still calling it syslinux. The folks who wrote syslinux were not real happy because when it broke it looked like it was their work that was the problem. I don't know if that conflict has been sorted out.

Since you use Ubuntu, try an experiment. Install usb-creator-gtk and its dependents. Depending on your enthusiasm you could check which syslinux package you have installed. A change may or may not correct anything, but simply complicate matters.

Use it (Startup Disk Creator) to remake the LiveCD. Try a dead-default installation. Boot with no modification. Check for persistence.

If that is successful; reboot, <F1>, other options, create 4GB persistency.

See if it gives the blue screen with the news that it's creating the 4GB file. If it does <hazzah>...if it breaks down somewhere in the process at least we can narrow it down to a stage.

Yes, the 6GB reference is outdated.

Author:  lschmid [ 23 Apr 2014, 03:14 ]
Post subject:  Re: Files wont save/Persistency Problem

Excellent troubleshooting skills! It fixed the problem. I could tell right away that things were different because the whole structure of the menu had changed. Persistency now works.

I am using Ubuntu 12.04 and the Unetbootin is already at least a year or two old.

One last question before I sign off. Should I keep my charts on the USB or should they go somewhere else?

Thanks very much for the help.

Author:  Moe [ 23 Apr 2014, 04:23 ]
Post subject:  Re: Files wont save/Persistency Problem

Where you put your charts, or anything for that matter, is a case of personal preference.

I tend to prefer defaults, as there is less to remember; hopefully, less to go wrong; and less effort to try and figure out 'what/where' if something goes squirrelly.

If space is an issue you can leave data on the hard drive and point all reference from the default locations to the 'new' location...doesn't really matter. You just have to remember what you did.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group