- A Voyager's Companion

Problem with USB GPS dongle
Page 1 of 1

Author:  Sailabout [ 02 May 2014, 04:25 ]
Post subject:  Problem with USB GPS dongle

I have created a Navigatrix USB stick (32 GB with 4 GB permanent section). All softs (I did not test the SSB ones as I have no radio) work properly but when I plug my USB GPS dongle (built by M. C. Marine, based on a U-Blox chip), Navigatrix does not respond to commands and only shows error messages basically telling that the home/nx directory cannot be found. Removing the USB GPS dongle does not remove the errors. After a “forced” manual reboot without the GPS dongle, Navigatrix works again.
Experimenting further on my Windows 7 machine, I found that I can access the files of the Navigatrix USB stick in Explorer when no GPS dongle is plugged-in or if the GPS dongle is plugged-in after the Navigatrix Stick. But if I plug the Navigatrix stick after the GPS dongle, the “USB device not recognized” message appears and the stick cannot be accessed.
Does anyone have some suggestions?


Author:  Moe [ 02 May 2014, 05:53 ]
Post subject:  Re: Problem with USB GPS dongle

Navigatrix does not respond to commands and only shows error messages basically telling that the home/nx directory cannot be found
Can you be more specific? Like what commands; where and when does it say it can't find home; does it volunteer that information, or do you have to try something? What are you trying? Will anything throw errors? Does the machine lock up, or just keep throwing errors?

Is the 'Windows 7 machine' the same one you are using to run Navigatrix? What make/model computer? What make/model gps? is a broken website and I can't find a reference to them having a 'u-blox' chipset.

Author:  David [ 03 May 2014, 03:11 ]
Post subject:  Re: Problem with USB GPS dongle

Eventualy when you put in the GPS into your USB port you may have touched the Navigatrix USB stick. Even if it disconnects only for a second the system will not work anymore since it lost access to the USB stick.

Author:  Sailabout [ 03 May 2014, 07:05 ]
Post subject:  Re: Problem with USB GPS dongle

Hello Moe

Yes, it is the same laptop I use for Windows 7 and Navigatrix. The M. C. Marine GPS dongle is based on the 5th generation of the U-Blox chip and uses U-Blox drivers.

I have put details and some picture in the attached document.

I guess my GPS dongle is creating incompatibilities with the other USB clients (memory sticks, SD card reader). I have updated the USB drivers, tried the 4 available USB ports of my laptop to no avail.

The problem is finally not a Navigatrix problem. It could be one of my laptop (or MS as I load drivers through Windows 7) but more probably a driver issue from U-Blox and/or Acer. I shall submit the issue to U-Blox and hope to receive an answer.


Author:  Moe [ 03 May 2014, 08:46 ]
Post subject:  Re: Problem with USB GPS dongle

David is right. Those are the errors of the USB being disconnected, even momentarily, from the system. Bad key, sloppy socket, bad's falling out of the system and can't just start up where it left off.

I would show you screenshots of what you have already seen, but, as you already have to reboot to get it to work again.

Author:  Sailabout [ 04 May 2014, 03:12 ]
Post subject:  Re: Problem with USB GPS dongle


It is certainly not a question of bad contacts, both GPS dongle and the Navigatrix stick are working perfectly when not working at the same time even when I manually touch them to check for bad contacts.

When booting from the Navigatrix USB stick, all function work until I plug the GPS dongle. After that, only what is in the computer memory (mouse control, display, ..) is working, all function needing to refer back to the stick reports an error. The Navigatrix USB stick is not recognized. There is clearly a conflict between the USB devices or their drivers.

I want to try this on my second laptop (an Asus eepc netbook) but until now I have not found a way to boot from the USB Navigatrix stick (thanks to the UEFI boot overlay!).


Author:  Moe [ 04 May 2014, 03:31 ]
Post subject:  Re: Problem with USB GPS dongle

I'll keep looking. This is indeed a curiosity. It warrants further exploration.

You should be able to do a "legacy" boot.

The setting should be in your "BIOS" UEFI settings.

Mine hide behind <F2> on powerup., really, tell yourself: "This is fun."

Let us know.

Author:  Sailabout [ 05 May 2014, 03:37 ]
Post subject:  Re: Problem with USB GPS dongle


I tried the USB 3.0 Navigatrix stick and the M.C. Marine USB 2.0 GPS dongle on my Asus eeePC and was successful. I have struggled to get the OpenCPN receiving the GPS data stream, but that is due to my ignorance of the Linux O.S. (Navigatrix is my first encounter with Linux). Could there be a way to render the connection between OpenCPN and device(s) data automatic?

I have yet to find a solution for the problem on my Acer laptop.

For information:
I have used the same drivers in the Asus eeePC as in my Acer Aspire machine. The eeePC runs Windows7 Enterprise (UEFI BIOS), the Aspire runs Windows7 Home Premium (regular BIOS).
I found the following for booting from the bootable USB stick, at least on my eeePC(with UEFI):
- the bootable USB 3.0 memory stick (Navigatrix in this case) should not be placed on the USB 3.0 port but on one of the USB 2.0 port
- the computer has to be cold started (do not use “restart”)
- In UEFI, click “Hard Drive BBS Priorities” to access the legacy devices and choose “USB Disk 3.0 PMAP” and not “UEFI : USB Disk 3.0 PMAP” (I do not know what is the difference)

Although a USB 3.0 is downward compatible with USB 2.0, the GPS dongle did not work when plugged in the USB 3.0 port of the eeePC and had to be plugged in a USB 2.0 port. In Windows7, this USB 3.0 port works perfectly, I usually use it for a USB 2.0 DVB-T receiver and have used it with the same GPS dongle in that USB 3.0 port in conjunction with Maxsea in the Gulf of Gascony last year.


Author:  Moe [ 05 May 2014, 07:52 ]
Post subject:  Re: Problem with USB GPS dongle

So..., it looks like there's something in the kernel/module setup/configuration that does not like USB3, or possibly a non-3 device (gps) in a 3.


What happens if you boot with the gsp already inserted? Or, if you plug in another usb thingy (not the gps)? Have you tried Navigatrix on an old stick with the the gps?

With regards to the system automagically picking up the gps. It does.

If you have modified any of the 'gps' settings it would be easier to troubleshoot is they were at the default settings. Sometimes, for me, I'll forget what I have changed, or changed multiple variables, make a typo,...and though I might have guessed the right setting, one of the other variables screws it all up and I don't recall which is which.

If I don't have much time invested in a system; it's sometimes easier to start over.

The u-blox chips have their own tags for gps sentences...possibly they did want anyone to know its capabilities.

The gpsd people know what those tags are. I'll look to see if there is a special switch were missing. If you could start off with default settings; start GPS Satellites....between the Skyview and the GPS Data is a line that may start out to look like:

This is no gps recognised in the system, but eventually should look similar to:

This is a gps signal that has yet to acquire a fix.

Please copy and cut the line when it recognises a gps. Please change any position data, paste and post it back here.

Author:  Sailabout [ 06 May 2014, 02:40 ]
Post subject:  Re: Problem with USB GPS dongle

Hello Moe

I am unable to experiment on the eeePC at the moment as my son borrowed it for a couple of weeks but the other day, I was able to boot from the USB 3.0 Navigatrix stick with the USB 2.0 GPS stick either plugged in or not plugged in, both devices plugged in USB 2.0 ports.

The GPS was not detected automatically although the GPSd Daemon was running in the background. After reading the OpenCPN instructions and found that the port was dev/ttyACM0, I could introduce this in the option “Connections” of OpenCPN and I got GPS data steam and my position on OpenCPN as shown in the attached photograph.


eeepc.JPG [ 562.12 KiB | Viewed 20638 times ]

Author:  Moe [ 06 May 2014, 03:35 ]
Post subject:  Re: Problem with USB GPS dongle

Yes, it's all a mystery. I've been reading up on USB and scratching my head.

Another mystery is the use of 'abstract control model' or ACM devices in gps-eses.

ACM is 'traditionally' for modems or 'computer-computer' communication.

There are a small number of USB/Serial converts set up this way and it's always been a mystery...but it is nice to see progress being made.

Author:  Sailabout [ 06 May 2014, 05:10 ]
Post subject:  Re: Problem with USB GPS dongle

Hello Moe

Well, it seems that Microsoft does not have all the solutions as quoted from dated May 22, 2013 - Revision: 12.0 with following title: "USB port may stop working after you remove or insert a USB device"

This problem may occur because of a timing issue that prevents the computer from detecting the USB device.
Microsoft and the hardware vendors that manufacture the chips that are used for USB have investigated the problem. However, the results were inconclusive because of the intermittent nature of the problem.

Microsoft is researching this problem and will post more information in this article when the information becomes available."

I guess I better get another GPS device ...


Author:  David [ 06 May 2014, 09:15 ]
Post subject:  Re: Problem with USB GPS dongle

If you go for a new gps, i would highly recommend a bu-353 gps mouse. It has good quality and a low price. Works great with navigatrix.

Author:  Sailabout [ 07 May 2014, 05:03 ]
Post subject:  Re: Problem with USB GPS dongle

Hello Moe

Problem solved!

The solution is not elegant but works very well: I plug my M.C. Marine USB GPS dongle in an external 7-port USB 3.0 hub (powered by an external power adapter) instead of directly in a port of my Acer laptop and, oh wonder, everything works fine.

Thank you for your support.


Author:  Moe [ 07 May 2014, 05:34 ]
Post subject:  Re: Problem with USB GPS dongle


Well done.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group