- A Voyager's Companion

installer failed
Page 1 of 1

Author:  david_302 [ 09 Oct 2014, 03:09 ]
Post subject:  installer failed


I've been trying to install the latest version on an eee-900 (the august 24 release) but i always get errors. I've downloaded the iso twice now off the torrent and the md5 matches. I've also tried using different usb sticks.

So I start the computer off the stick and run the install. Right at the end of the install i get the error below, and then when i click ok to this, it says its failed to install the bootloader. Any ideas whats going on? I havent had any issues with previous releases.


An error occurred while installing packages:

E:Archives directory /target/var/cache/apt/archives/partial is missing. - Acquire (2: No such file or directory)

The following packages are in a broken state:

This may be due to using an old installer image, or it may be due to a bug in some of the packages listed above. More details may be found in /var/log/syslog. The installer will try to continue anyway, but may fail at a later point, and will not be able to install or remove other packages (possibly including itself) from the installed system. You should first look for newer versions of your installer image, or failing that report the problem to your distributor.

Author:  Moe [ 09 Oct 2014, 05:54 ]
Post subject:  Re: installer failed

I've seen this error, and I don't see how it can bork an install. I mean, it could, but i don't see how it would.

What is happening is the image you downloaded doesn't have a directory called 'partial' as you see here
moe@lenny:/var/cache/apt/archives$ ls
lock  partial
...partial is where the partially downloaded software packages are stored before they wind up in /var/cache/apt/archives. This directory is generally empty.

The fact that it is missing will disappear the first time you run the Package Manager (synaptic).

If it is indeed goofing up your install, and it could be possible, the remedy is to create it. The problem is where it would be created.

Us mere mortals have capabilities to create the file either by running the Package Manager or by
sudo mkdir /var/cache/apt/archives/partial
but the directory is really *in* (or not in, because it's lacking in) the squashfilesystem of the compressed file (/casper/squash.fs) packed away in the ISO you have already downloaded twice.

It is my understanding this is the file referenced (/casper/squash.fs) when we install the system, but shouldn't have a bearing on the process....but then it wouldn't be the first time I was wrong.

Firing up the Package Manger, or manually creating the directory. It may make the error go away, but I don't see how it would effect the installation.

Author:  david_302 [ 09 Oct 2014, 14:49 ]
Post subject:  Re: installer failed

Thanks Moe, I'll give that a go.

Could it cause the boot loader to fail to install? I've never had a problem with this before, but it comes up with the boot loader failure straight after the error message about the missing directory.

Author:  Moe [ 09 Oct 2014, 15:44 ]
Post subject:  Re: installer failed

By all means it could. It would be nice if software could handle what should be a non-fatal error, like a gnat in the soup; in the big picture it means nothing just close your eyes and keep eating.

This is actually less than a gnat because it is something missing that can be created from nothing.

But, Awyup!, something's not right here, no "partial" directory. Start over. It could happen. I don't know why it would (need to), but it could.

Author:  david_302 [ 23 Oct 2014, 21:16 ]
Post subject:  Re: installer failed

I'm still having trouble trying to do a local install with the aug14 release (i tried an older release I had from feb14 and that worked fine).

Each time I try to install the latest release, the boot loader fails to install. I tried this:
sudo grub-install --recheck --no-floppy --root-directory=/ /dev/sdb

and I get the response:
Installing for i386-pc platform.
grub-install: error: failed to get canonical path of '/cow'.

Any suggestions? I'm not really sure how to install the boot loader… What might have changed on the latest release to cause it not to install on my machine?

Author:  Moe [ 24 Oct 2014, 06:19 ]
Post subject:  Re: installer failed

Let's get a running start on this.

I assume you have checked the MD5 checksum, because you will say "Yes, I have an intact copy and I am not trying to do any thing freaky-deeky."

Try this:

Boot up with a LiveCD.

Partition the drive you are going to use. ( I found at least 3 partitions, /, /home, and swap. Try at least 10GB for root, if not more. Something less can lead to tears. If you're tight on space you can cheat swap. E.g., this machine has 4GB RAM and 1GB swap, which I don't really need.)

Format the partitions, still with the Partition Editor (gparted). Your choice, within reason.

Close gparted and open the installer.

Install with the Something Else method, and hand place the file structure in the partitions you have prepared.

Stick with defaults the rest of the way out.

Now, let's see if it spits up and we're still having fun.

Author:  david_302 [ 29 Oct 2014, 01:00 ]
Post subject:  Re: installer failed

You were right, less than 10GB = tears.

The netbook I'm using has a 15gb and a 4gb drive. I had been installing navigatrix on a 7gb partition, leaving the remaining space for /home and swap. The previous versions seemed to work fine on 7gb, not so much with the new version. I re-partitioned to 10gb, and the install worked just fine.

Thanks for your help! Sorry it ended up being a silly mistake!

Author:  Moe [ 29 Oct 2014, 01:17 ]
Post subject:  Re: installer failed

No worries, I've made that particular mistake a few times myself.

With only 15GB drive you can go smaller for the root partition. The 10GB was an arbitrary limit that gives enough space for future addition of software without cramping anyone's style...except those without a lot of drive space.

I don't know what the 'real' minimum for a root partition would be to not waste space, but then nothing could be added. In special cases, such as yours, putting the whole installation on one partition would use the space more efficiently, but keeps you on the straight and narrow with regards to future flexibility.

Author:  david_302 [ 30 Oct 2014, 18:29 ]
Post subject:  Re: installer failed

Yep, for now I'm using 10gb for the root "/" and 4 gb for /home. I formatted the seperate 4gb drive with the aim of just using it to store charts. When I installed navigatrix I did not choose to mount it with anything in particular. Now when I try to write anything to it it says permission denied. Is there anything I need to do to allow access to it? And can I redirect home/charts to this other drive?

Author:  uncndl1 [ 30 Oct 2014, 19:20 ]
Post subject:  Re: installer failed

Question, are you using Linux to download the iso? or are you using Windows??

Author:  Moe [ 30 Oct 2014, 21:02 ]
Post subject:  Re: installer failed

The device or filesystem on the device most likely belongs to root and you don't have write privilege.

sudo chown -R user:group /the_directory/you_want_recursive_permission

For example:

As root I created and unpacked an ISO in the /media directory. Everything in the /media directory is owned by root.

sudo chown -R moe:moe /media/ISO/

transfers ownership of the ISO directory and everything in it to me while the parent (/media) still stays with root.

You can place charts, or whatever, anywhere your heart desires as long as you remember where. (Actually remembering isn't essential for the process, but it is helpful.)

Author:  David [ 02 Nov 2014, 23:49 ]
Post subject:  Re: installer failed

If there is a problem installing the boot loader you can do it manually. To do this follow these steps:

1. Boot from the live USB stick.
2. Once booted go into the terminal and get root access with the command sudo su
3. Change into the folder where your internal harddrive with the linux system is mounted. The one you want to make bootable.
It may be possible with cd /media/system if your installed system is on a partition with name system.
You may need to change /media/system with another name that is valid for your installation. You should be able to see the correct
name and location within the file-manager.
4. Enter these commands:
mount --bind /dev dev/
mount --bind /sys sys/
mount --bind /proc proc/
chroot .
grub-install /dev/sda

If your system is not on /dev/sda you have to change the parameter for grub-install to the name of the hard drive where your system is installed, but usually its /dev/sda. Hope this fixes your issue.

Author:  Didier B [ 31 Aug 2015, 12:50 ]
Post subject:  Re: installer failed

Hi Everybody

It sems I had the same problem when installing Navigatrix on a EeePC 900 :

I first installed it on a EeePC 901, (SSD = 16 Gb) without any problem. Then I tried to install Navigatrix (from the stick) on a EeePC 900, (2 SSD :4 + 8 G), and the installation failed with a message about lack of disk space. When retrying, I noted that 8.3 Gb where required (Oooops !).

So far, the only work around would be to have a double boot :
- A Lubuntu 14.04 LTS (e.g.) on the SSD 8.1 Gb ;
- Navigatrix 0.5 on the SD card (16 Gb).

If someone can suggest another approach (e.g. using LVM ?), I'm ready to explore (Though I have no skill in Linux disk formats...)

Author:  Moe [ 02 Sep 2015, 03:31 ]
Post subject:  Re: installer failed

Here's an idea.

Hard drive is partitioned for the root /, (I swear I made the virtual machine drive 8GB.)

the card will be /home,

this should contain all the system configurations changes made as a user, email, browser configuration files and personal data, can be encrypted on the fly (surprisingly low overhead too) so the pop-in pop-gone aspect doesn't matter.

I fire up the LiveCD Navigatrix. Using the Partition Editor I partition and format the hard drive (probably /dev/sda). Pick a format; why not ext4? You do the same for the 16GB card, leaving off as much swap as you want

(Rule of thumb has been amount of memory = swap size. You should never need this whole amount, you can go smaller to *none-at-all*. Some is good, more is better, never never is never, it just might be too improbable to worry about. You choose.)

I created three partitions:
  • /dev/sda1 Labelled root
  • /dev/sdb1 Labelled home
  • /dev/sdb2 swap

The easiest way to mount them is with the File Manager.
File comment: mount them
002.png [ 41.45 KiB | Viewed 27268 times ]
Now launch the Hard Drive Installed, it's called ubiquity, from the commandline.

You are then are asked if you'd like to unmount the drives you have just mounted.
To keep the magic juju going, I said "Yes". "No" means you didn't unnecessarily mount the drives in the previous step and waste time. I learned this later. Experiment at your leisure.
File comment: unmount
003.png [ 40.26 KiB | Viewed 27268 times ]
I then selected Something else,
File comment: something else
004.png [ 46.34 KiB | Viewed 27268 times ]
Change your installation to match your intended mounting points
005.png [ 46.54 KiB | Viewed 27268 times ]
Make sure GRUB goes on to the appropriate drive (which I swear I made 8GB), and then commit.

It looks like this, with some overhead for the virtualbox. If you do this, the number will vary.
006.png [ 72.03 KiB | Viewed 27268 times ]

Author:  Didier B [ 05 Sep 2015, 11:04 ]
Post subject:  Re: installer failed

hi Moe,
and all my thanks for your elaborated answer !
Unfortunately, my both tries (I thought I missed something on the first try, so I did it again, cross checking any action) failed with the same error message. (All installation process run to the end, without error message, and on the reboot (from the disk) I got the following :

error : no such device : 7b3627dd-f13e-4381-a888-d6326c6440d5.
Entring rescue mode...
grub rescue> _

At that point, I am stuck !

Author:  David [ 05 Sep 2015, 16:36 ]
Post subject:  Re: installer failed

did you try again what i suggested further up this post....all the steps for doing grub-install booting from the usb stick ?

Author:  Moe [ 05 Sep 2015, 18:53 ]
Post subject:  Re: installer failed

I tried with a 6GB harddrive, and a secondary 16GB drive.

If you try to place the root / on one device and /home on the other without splitting it up further will cause an error. root (/) minus /home requires 6.5GB.
Smallest_unsegmeted_root_partition.png [ 63.63 KiB | Viewed 27251 times ]
You are not getting that error. You're getting a GRUB error, most likely from a mismatched UUID tag.

Try booting from the USB, and then using the Partition Manager to repartition both devices to give you a clean slate upon which to write the system.

It is important the GRUB is loaded onto /dev/sda1, which should be your root / partition.

Author:  Didier B [ 09 Sep 2015, 10:42 ]
Post subject:  Re: installer failed

Third failure... May be the point is that in my EeePC 900, the 2 volumes (4,8 Gb) are IDE, and the Master is the volume of 4 Gb.

Anyhow, enough with that, I sold the EeePC 900 to acquire another EeePC 901, with a single volume which should solve the case !

(I have other points to discuss, so I will open new discussions...) Thanks for the help !

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group