- A Voyager's Companion

Iridium doesn`t connect...
Page 1 of 1

Author:  svattila [ 28 Jan 2015, 16:10 ]
Post subject:  Iridium doesn`t connect...

Hello, NX-ers!

I have bveen using Wvdial to connect to the internet using my iridium phone since years, but now i have a problem which I can not resolve....
I recently changed my SIM card, and the phone works fine using this new sim card, but every time I try to connect to the internet, the dialer gives the command ATDT008816000025, waits a little bit, and then returns: No Carrier! Trying again....... and so on.... but it never connects.
The only difference between the old and the new SIM card is that while the old one dialed the number immediately after punching the numbers in, the new one gives me the remaining account balance and expiration date after dialing the number. This statement takes about 10 seconds...
To me it looks like the dialer should wait for a longer time, to pass this statement before it could detect a carrier, please correct me if I am wrong...
Any ideas how to solve this problem?
If I manually dial 008816000025, and wait until the lady finishes with the account balance, I can clearly hear the chirrupping of the carrier signal....
Thank you!

2015-01-25_151553_600x339.png [ 85.97 KiB | Viewed 21901 times ]

Author:  Moe [ 28 Jan 2015, 20:03 ]
Post subject:  Re: Iridium doesn`t connect...

A stab in the dark Adrian,
gksu medit /etc/ppp/options
Down towards the bottom of the file is
# Wait for up n milliseconds after the connect script finishes for a valid
# PPP packet from the peer. At the end of this time, or when a valid PPP
# packet is received from the peer, pppd will commence negotiation by
# sending its first LCP packet. The default value is 1000 (1 second).
# This wait period only applies if the connect or pty option is used.
#connect-delay <n>
Remove the # on the last line to something like
connect-delay 10000
for a 10 second pause.

Save and test.

Or, you could try adding
Dial Timeout =10
to end of the wvdial.conf file you're using. Save and test. Increasing/decreasing the value to suit.

Your choice of either one modification or the other, but not both.

Author:  svattila [ 29 Jan 2015, 02:38 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

Ayay. :) I tried both methods, no success. I tried both files, from 5 to 40 seconds of delay, but no difference in the frequency of the No Carrier! Messages... After each attempt to call, it comes back with the No Carrier! message, way before the set -say 30 seconds have expired.
I Think my problem is before this, I think at the dialing stage. The phone gives this li-la-li sound every time right after ATDT008816000025 command is given... it is like he is calling the wrong number, or gives the wrong dial command, way before they would wait for the carrier....
Any ideas?

Author:  Moe [ 29 Jan 2015, 04:31 ]
Post subject:  Re: Iridium doesn`t connect...

Oh, bugger, the cursed li-la-li sound....;-)

Does it make the li-la-li sound when you hand dial?

Oh, and you did edit those files as root? gksu medit /blah/blah/blah, right?

Hang on...Is this dialing, and hanging up with the lovely lady recording telling you about your balance, or is it picking up and saying there is no carrier (dial tone) to know when to begin to dial?
There are a few 'dirty' hacks you could try...

Carrier Check = no
to your wvdial.conf

Author:  svattila [ 29 Jan 2015, 20:23 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

I tried Carrier Check = no in the .conf file, but it still waits for the carrier...
When I hand dial the number for the data service, it just tells me my account balance, then rings the server, and the server starts singing the carrier sound in my ear...
When Wvdial tries to dial, it always runs into the cursed li-la-li sound :)
Yes, when I edited the said files I had sudo rights....
What this problem could be?
Could I just manually dial the number, and tell the computer to start listening when i got the carrier signal? Or any other ideas?


2015-01-29_151719_1360x768.png [ 201.12 KiB | Viewed 21891 times ]

Author:  Moe [ 29 Jan 2015, 21:21 ]
Post subject:  Re: Iridium doesn`t connect...

If I'm hearing you correctly the la-li-la is an error tone. I just don't where it's coming from, nor do I know how you could use it like the old acoustic couplers where we use to dial and when it started to squeal-slap it into the holder.

Try changing Init2 to
Init2 = ATS9=10V1X4E1Q0&c1
S9 Carrier Detect Response Time 1–255 tenths of a seconds 6 (0.6 second) setting it to 10 give a one second delay to figure out the carrier. X4, well the X4 "Usually adds both busy signal and dial tone detection" "Usually" comes from the original documentation of Hayes Command Set, the alphabet soup in the init lines

Give changing the init2 a go, and in the meantime I'll charge up the phone, and see if I can play along in the next few days.

Author:  svattila [ 29 Jan 2015, 23:40 ]
Post subject:  Re: Iridium doesn`t connect...

I changed the Init line in the config file. Now it does make a difference. Now it waits longer before quitting with the li-la-li errror code...
hmm... it is getting frustating. :)


Author:  Moe [ 30 Jan 2015, 00:43 ]
Post subject:  Re: Iridium doesn`t connect...

The good thing is you know you're messing with the right configuration file;-)

I'm asking myself two questions:
1) What is different about the old sim and the new sim?
2) What is the difference between hand dialling and machine dialling?

I'm making some assumptions that hand dialling is hiding delays in the system. For example, checking the account of the reseller, who checks if you still have the go-ahead. Hand dialling is slow, a few milliseconds here, a few there, no one is the wiser.

On the other hand machines don't hesitate unless a lag is built in, or inherent, to the system. A machine on one end will dialling away while the other end is still checking permissions, la-li-la, I'm not ready.

It could be the speed of the tones (DTMF) themselves, how fast the dial.
S11 DTMF Tone Duration Range: 50–255 milliseconds Default: 95 milliseconds
The default of 95 milliseconds might be too fast compared to hand dialling, that is. We don't really know because we're guessing, and when you hand dial, and an assumed slower hand dialling speed might be enough, S11=150 added to the init script could be the trick.

Then again, the cumulative wait time of an extra 55 milliseconds per tone might push you off the deep end.

Author:  svattila [ 30 Jan 2015, 12:55 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

Where do I insert this command? I mean which Init line I have to modify?
Is the text to be inserted looks like this: S11 = 200
I think we are getting closer to the solutrion... Lets see.


Author:  svattila [ 31 Jan 2015, 13:07 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

I added S11=150 to the Init line, but it did not help my problem. What this problem could be?
We are planning to go to the sea for like 90 days very soon, and it would be nice to receive weather data.
Any other suggestions?


2015-01-31_080430_1360x768.png [ 186.02 KiB | Viewed 21881 times ]

Author:  Moe [ 01 Feb 2015, 05:31 ]
Post subject:  Re: Iridium doesn`t connect...

Isn't that the way it always goes...down to the crunch and then some snafu.

It was the reason we got the sat phone to begin with. It always seemed the SSB would spit up the week, or so, before we left.

So to help diagnose your difficulty, I drag out the phone.

I forgot with Iridium, after a period of time, any remaining minutes on the sim card disappeared. Iridium, however, did not forget...bugger! there were over 100 minutes left.

To add insult to injury, I am no closer to figuring your situation out.

Who is the reseller of your sim? Maybe we can find something there.

In the meantime, place a comma , at the beginning of the phone number
Phone = ,008816000025
and cross your fingers, or the Hungarian equivalent.

Author:  svattila [ 02 Feb 2015, 17:38 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

I`ve bought the card from assystems in Tahiti... Seems like all the other sims I purchased before....
Well, I`ve tried with the comma (,) but it still doesn`t connect. I have to go on the sea for 2 days, I will check again later, meanwhile I will experiment with it, too....

Thank you for your help, Moe!

Author:  Moe [ 02 Feb 2015, 22:41 ]
Post subject:  Re: Iridium doesn`t connect...

Those dang Customs and Importation laws.... Good luck.

I spent the morning going over the original source from University of New South Wales professor, Michael Ashley.

He wrote the original wvdial script for his phones in Antarctica, and had the forethought to have local copies of his reference sources in case they 'disappear from the original sites'.

I've gone through his references, and a few other on the 'net, and I'm no more the wiser as the cause of your troubles. Your phone is a 9500 with a serial/usb adapter, right? (in some of the nitty-gritty there's a difference between 9500/9505 in compliance with AT commands...go figure...) I'll put it on the back burner, but anything I have to add at this point is just more blind speculation. Sorry.

Author:  Moe [ 02 Feb 2015, 23:18 ]
Post subject:  Re: Iridium doesn`t connect...

One question I had was, "Does this new sim have data capabilities on the account?"

From Iridium's troubleshooting guide, The SIM card must be provisioned for data. wrote:
Phone is registered, but cannot make a dial-up data connection.

Verify that the phone is displaying good signal strength.
The SIM card must be provisioned for data. If in doubt, contact your Service Provider.
Check the software version in the phone by pressing *#91# on the keypad. The Motorola
9500 must show software version INC0620 or later. The Motorola 9505 must show software
version LAC109G or later. The Motorola 9520 must show software version RAC0620 or
later. (Newer data-capable versions may be released from time to time, and will be indicated
by a higher numerical sequence.)
Check the cable connections.
Check to see that the dialed phone number is accurate, and that it was dialed in international
format (00 + Country Code + Area Code/Phone Number).
For example, if you are dialing an ISP in Tempe, Arizona, USA, you would enter
00 1 480 555 5555, where 1 is the country code and 480.555.5555 is the ISP’s telephone
number. You can verify that you are dialing the correct number by dialing the number as a
voice call from your Iridium phone. You should hear your ISP’s modem tones if dialed

Verify that your settings have not changed (modem properties, phone number, user name,
password, etc.)
Is your Iridium handset dialing? While dialing, the Iridium handset blinks “Data Call in
Progress”. If not, cycle the power on the phone to reset it.
...and so it goes.

The phone number is correct; the firmware in the phone is fine; I'm just not sure about the rest.

I'd also recommend if you want to make your brain hurt...but it could just be a voice-only sim.

Assystem Polynésie was too confusing for me to untangle.

Author:  svattila [ 04 Feb 2015, 18:18 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

My phone is a 9505, and the software version is the LAC109G. It connects to the computer through the serial port, no Serial to USB converter is being used.
I`ve sent an email to assystems in Tahiti, to ask them about the data permissions for my sim card. Let`s hope they come back with something useful.


Author:  svattila [ 28 Feb 2015, 17:36 ]
Post subject:  Re: Iridium doesn`t connect...

Hello, Moe!

I got the response from assystems and -yes- he forgot to activate the data service....
Now that he did activate it it works fine with the original config file.
One little problem remains:
Every time I turn the computer on, it forgots the settings.
So to use the satphne I have to do this exact sequence:
Turn on computer, connect and power up satphone
run sudo wvdialconf /etc/wvdial.conf
wvdialconf gets everything right, exept the speed, so I have to sudo gedit /etc/wvdial.conf and change 11500 to 19200 then save it.
Now when I click on the stellite icon, it connects and works fine.
But if I turn off the computer, I will have to do again the wvdialconf and therefore the gedit, too.
I looked into it, and the wvdial.conf file gets saved OK, with the 19200, but it still does not work, only after re-running wvdialconf ....
Any ideas why this happens?


Author:  Moe [ 22 Apr 2015, 23:11 ]
Post subject:  Re: Iridium doesn`t connect...

Adrian would you run
ls -lisa /etc/wvdial*
It will look something like
moe@io:~$ ls -lisa /etc/wvdial*
524586 4 -rw-r--r-- 1 root root 230 Aug 13 2014 /etc/wvdial.conf
524587 4 -rw-r--r-- 1 root root 243 May 14 2014 /etc/wvdial.conf.iridium0
524588 4 -rw-r--r-- 1 root root 251 May 14 2014 /etc/wvdial.conf.iridium1
524589 4 -rw-r--r-- 1 root root 230 Jun 13 2013 /etc/wvdial.conf.isatphone0
524590 4 -rw-r--r-- 1 root root 234 May 14 2012 /etc/wvdial.conf.isatphone1
we are just checking ownership (root root) and permissions (rw-r--r--).

Author:  svattila [ 23 Apr 2015, 11:42 ]
Post subject:  Re: Iridium doesn`t connect...

Here is the return:
nx@navigatrix:~$ ls -lisa /etc/wvdial*
536722 4 -rw-r--r-- 1 root root 294 Feb 27 08:54 /etc/wvdial.conf
548649 4 -rw-r--r-- 1 root root 266 Feb 4 13:25 /etc/wvdial.conf.iridium0
522540 4 -rw-r--r-- 1 root root 274 Feb 4 13:26 /etc/wvdial.conf.iridium1
522541 4 -rw-r--r-- 1 root root 230 Jun 12 2013 /etc/wvdial.conf.isatphone0
522542 4 -rw-r--r-- 1 root root 234 May 13 2012 /etc/wvdial.conf.isatphone1


Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group